Bug 977715 - attempting 19 Final RC1 minimal text install installs GNOME instead
attempting 19 Final RC1 minimal text install installs GNOME instead
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
19
All Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Vratislav Podzimek
Fedora Extras Quality Assurance
AcceptedBlocker
:
Depends On:
Blocks: F19Blocker/F19FinalBlocker
  Show dependency treegraph
 
Reported: 2013-06-25 04:15 EDT by Andre Robatino
Modified: 2013-06-28 03:17 EDT (History)
13 users (show)

See Also:
Fixed In Version: python-blivet-0.17-1.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-28 03:17:10 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andre Robatino 2013-06-25 04:15:21 EDT
Description of problem:
Attempting to do a minimal text install from the 19 Final RC1 DVD (either i386 or x86_64) installs GNOME instead. This worked properly in 19 Final TC6 (anaconda-19.30.9-1).

Version-Release number of selected component (if applicable):
anaconda-19.30.11-1

How reproducible:
always
Comment 1 Kamil Páral 2013-06-25 04:17:11 EDT
Reproduced. This is most probably caused by:

> commit c9fab0b
> Author: Samantha N. Bueno <sbueno+anaconda@redhat.com>
> Date:   Thu Jun 20 11:44:07 2013 -0400
> 
>     Fix issue where default DE not actually installed in TUI (#972592)
>     
>     If a user leaves the default option to install Gnome, make sure
>     the selection is actually applied.
Comment 2 Kamil Páral 2013-06-25 04:21:11 EDT
Proposing for blocker bug discussion, even though we have only GUI requirements:

When doing a graphical install using the dedicated installer images, the installer must be able to install each of the release blocking desktops, as well as the minimal package set. 
https://fedoraproject.org/wiki/Fedora_19_Alpha_Release_Criteria

It seems that this criterion should be strengthened in Beta or Final, but I don't see it there.
Comment 3 Kamil Páral 2013-06-25 04:29:48 EDT
Netinst is also affected by this bug. Currently the only known workaround is to use GUI mode, which is not affected (VNC should also probably work).
Comment 4 Vratislav Podzimek 2013-06-25 07:52:38 EDT
(In reply to Kamil Páral from comment #1)
> Reproduced. This is most probably caused by:
> 
> > commit c9fab0b
> > Author: Samantha N. Bueno <sbueno+anaconda@redhat.com>
> > Date:   Thu Jun 20 11:44:07 2013 -0400
> > 
> >     Fix issue where default DE not actually installed in TUI (#972592)
> >     
> >     If a user leaves the default option to install Gnome, make sure
> >     the selection is actually applied.
This patch just revealed an issue that had already been in the code.
Comment 5 Vratislav Podzimek 2013-06-25 08:46:57 EDT
Patch fixing this issue posted to anaconda-patches. Please test the change with the following updates image:

http://vpodzime.fedorapeople.org/977715_updates.img
Comment 6 Josef Skladanka 2013-06-25 09:14:25 EDT
(In reply to Vratislav Podzimek from comment #5)

The updates.img fixes the bug for me.
Comment 7 Andre Robatino 2013-06-25 09:31:55 EDT
Patch works for me on a minimal 19 Final RC1 i386 DVD install.
Comment 8 Adam Williamson 2013-06-25 11:51:58 EDT
+1 blocker, minimal install is one of the more important cases for text mode.

Kamil, the criterion specifies graphical mode because when it was written, there was no package selection for text mode. Until F19, interactive text mode could *only* install the minimal package set.
Comment 9 Jaroslav Reznik 2013-06-25 11:58:04 EDT
+1 blocker if my vote would be needed meanwhile as I'd say minimal install and text mode goes together pretty well.
Comment 10 Kevin Fenzi 2013-06-25 12:08:50 EDT
+1 blocker
Comment 11 Adam Williamson 2013-06-25 12:31:55 EDT
That's +3 at least, setting AcceptedBlocker.
Comment 12 Dennis Gilmore 2013-06-25 12:54:56 EDT
+1 blocker for the record
Comment 13 Adam Williamson 2013-06-25 21:52:42 EDT
Confirmed fixed in RC2, minimal install from text mode works. Also confirmed that the default GNOME selection also works.
Comment 14 Fedora Update System 2013-06-26 00:01:31 EDT
python-blivet-0.17-1.fc19, anaconda-19.30.12-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/FEDORA-2013-11679/python-blivet-0.17-1.fc19,anaconda-19.30.12-1.fc19
Comment 15 Fedora Update System 2013-06-28 03:17:10 EDT
python-blivet-0.17-1.fc19, anaconda-19.30.13-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.