Bug 977717 - Key shortcuts with Alt are not working for some languages
Key shortcuts with Alt are not working for some languages
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Installer (Show other bugs)
6.1.1
Unspecified Unspecified
unspecified Severity low
: ---
: EAP 6.1.1
Assigned To: Francisco Canas
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-25 04:20 EDT by Petr Kremensky
Modified: 2014-09-03 00:57 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
In previous versions of the JBoss EAP 6 installer there existed an issue where the keyboard shortcuts for buttons would not work for some languages. This happened where the starting letter for the button's label, which was indicated as a keyboard shortcut, was the same as another. For example: The Spanish button for +*Next*+ is +*Siguiente*+, and +*Cancel*+ is +*Salir*+. Both Spanish buttons would be displayed with an underlined +S+, indicating a keyboard combination of +*Alt+S*+. However that keyboard combination would only the trigger +*Salir*+ (+*Cancel*+) button, and there would be no keyboard combination that would trigger the +*Siguiente*+ (+*Next*+) button. In this release of JBoss EAP 6, all buttons displayed on each step of the installer now have a unique underlined letter, indicating the functioning keyboard shortcut.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-16 16:26:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petr Kremensky 2013-06-25 04:20:44 EDT
Description of problem:
In French word Next=Suite and word Cancel=Sortie (both with underlined S as shortcut button for combination with Alt), but combination Alt+S triggers Cancel button and there is no combination for Next button (Alt + [ortie] does nothing).

This is same for Spanish (Next=Siguiente, Cancel=Salir).

There are also two Browse buttons in Maven Repository Setup screen and Alt+B triggers only lower one.

Version:
EAP 6.1.1 ER1

How reproducible:
always

Steps to Reproduce:
1. run graphical installer in Spanish
2. try to press next button using combination with Alt button
Comment 1 Francisco Canas 2013-06-25 16:10:40 EDT
Installer will now attempt to assign the button's keyboard shortcut based on the next letter in its caption, if the first letter is already in use by another button in the panel. Example: [S]uite and S[o]rtir.

The shortcuts for the two browse buttons in the Maven Repository are also set this way.

See commit for details:
http://git.app.eng.bos.redhat.com/?p=izpack.git;a=commit;h=f30baf8711f47c2f3bb56fd2a02c894680d8f66d
Comment 2 Francisco Canas 2013-06-26 17:01:11 EDT
Added a more general fix to the button keyboard shortcut collision issue:

- InstallerFrame buttons (help, next, previous, quit) now reserve their respective keyboard shortcuts before any panel buttons are generated. 
- Using a button shortcut map to avoid shorcut collisions within each panel. 

See commit for details:
http://git.app.eng.bos.redhat.com/?p=izpack.git;a=commit;h=9f27457495d4df3e2f4d3e51f54c08f96f788e87

Some discussion:

- Languages that use symbols instead of letters (ie. Chinese) may not be able to use these keyboard shortcuts since each character may need several keystrokes to enter. Need to have further discussion about how to handle keyboard shortcuts for symbolic text buttons.
- Should there be a standard, language-independent set of shortcut keys for the 4 main installerFrame buttons? For example: Enter->Next, Backspace->Previous, Esc->Quit, F1->Help.
Comment 3 Petr Kremensky 2013-07-08 10:01:12 EDT
Verified on EAP 6.1.1 ER2.

Note You need to log in before you can comment on or make changes to this bug.