Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 977755 - Datetimepicker does not disappear after selecting minutes
Summary: Datetimepicker does not disappear after selecting minutes
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss BPMS Platform 6
Classification: Retired
Component: Business Central
Version: 6.0.0
Hardware: Unspecified
OS: Unspecified
medium
low
Target Milestone: ER2
: 6.0.0
Assignee: Mauricio Salatino
QA Contact: Jan Hrcek
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-06-25 09:20 UTC by Jan Hrcek
Modified: 2014-08-06 20:08 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: The widget used for setting date & time fields does not disappear after the date&time has been fully specified by it. Consequence: After selecting minutes, the datetimepicker still remains displayed. Fix: This is one of the standard gwt bootstrap component and the code to fix this issue has now been updated. Result: The datetimepicker widget now disappears on selecting the minutes.
Clone Of:
Environment:
Last Closed: 2014-08-06 20:08:38 UTC
Type: Bug


Attachments (Terms of Use)

Description Jan Hrcek 2013-06-25 09:20:43 UTC
Description of problem:
The widget used for setting date & time fields does not disappear after the date&time has been fully specified by it.

Version-Release number of selected component (if applicable):
jBPM console DR5 deployed on JBoss EAP 6.1

How reproducible:
Always

Steps to Reproduce:
1. Navigate to BPM > Tasks - Grid View (Advanced view)
2. Click "New Task"
3. Click "Due On" input field to bring up datetimepicker widget
4. Select some values for days - hours - minutes

Actual results:
After selecting minutes datetimepicker remains displayed.

Expected results:
After selecting minutes the datetimepicker widget should disappear (as is the current behavior of of datepicker after selecting days)

Additional info:

Comment 1 Mauricio Salatino 2013-07-04 13:26:39 UTC
This is the standard gwt bootstrap component, which doesn't seem to be working on a Modal. Because the code to fix this issue is not in the jbpm console ng code, there is not much that I can do with it.

Comment 2 Mauricio Salatino 2013-07-11 08:12:45 UTC
fixed in master. Needs testing to see if the current behavior is what you were expecting

Comment 3 Jan Hrcek 2013-09-04 07:31:56 UTC
Mauricio: yes, the current behavior is what I expected. Thanks for the fix!

Verified with BPMS 6.0.0.ER2

Comment 7 Kanchan Desai 2013-10-29 08:27:14 UTC
Hi Jan,

Doc Text has been added. Can you please review the CCFR.

Comment 8 Jan Hrcek 2013-10-29 08:29:56 UTC
Hi Kanchan,
yes, it's correct.


Note You need to log in before you can comment on or make changes to this bug.