Bug 977774 - fail to ordinal create external snapshot with vmdk format one by one
fail to ordinal create external snapshot with vmdk format one by one
Status: CLOSED DUPLICATE of bug 977767
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
6.5
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Fam Zheng
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-25 06:06 EDT by Sibiao Luo
Modified: 2013-07-02 20:51 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-02 20:51:45 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sibiao Luo 2013-06-25 06:06:21 EDT
Description of problem:
make a vmdk format image, then create first external snapshot1 with the backing file, then create second external snapshot2 with snapshot1 as backing file. but it fail to crate snapshot2 with prompt 'No such file or directory'. btw, qcow2 have no such issue.
e.g: base<-----snap1<-------snap2<----...

Version-Release number of selected component (if applicable):
host info:
2.6.32-392.el6.x86_64
qemu-kvm-0.12.1.2-2.376.el6.x86_64

How reproducible:
100%

Steps to Reproduce:
1.create a vmdk format disk.
# qemu-img create -f vmdk vmdk-data-disk.vmdk 10G
Formatting 'vmdk-data-disk.vmdk', fmt=vmdk size=10737418240 compat6=off zeroed_grain=off 
# qemu-img info vmdk-data-disk.vmdk 
image: vmdk-data-disk.vmdk
file format: vmdk
virtual size: 10G (10737418240 bytes)
disk size: 12K
2.create first external snapshot1 with the backing file.
# qemu-img create -f vmdk -b vmdk-data-disk.vmdk vmdk-data-snapshot1
Formatting 'vmdk-data-snapshot1', fmt=vmdk size=10737418240 backing_file='vmdk-data-disk.vmdk' compat6=off zeroed_grain=off 
# qemu-img info vmdk-data-snapshot1
image: vmdk-data-snapshot1
file format: vmdk
virtual size: 10G (10737418240 bytes)
disk size: 12K
backing file: disk.vmdk
# ls -lh vmdk-data-snapshot1
-rw-r--r--. 1 root root 1.4M Jun 25 17:56 vmdk-data-snapshot1
3.create second external snapshot3 with the backing file.
# qemu-img create -f vmdk -b vmdk-data-snapshot1 vmdk-data-snapshot2

Actual results:
after step 3, it fail to crate snapshot2 with prompt 'No such file or directory'.
# qemu-img create -f vmdk -b vmdk-data-snapshot1 vmdk-data-snapshot2
Could not open 'vmdk-data-snapshot1': No such file or directory

Expected results:
it should can ordinal create external snapshot with vmdk format one by one. 

Additional info:
Comment 1 Fam Zheng 2013-07-02 20:51:45 EDT
Dup of 977767, close this one as the other has more information.

*** This bug has been marked as a duplicate of bug 977767 ***

Note You need to log in before you can comment on or make changes to this bug.