Bug 977792 - [abrt] openstack-swift-container-1.8.0-2.fc19: socket.py:224:meth:error: [Errno 99] Cannot assign requested address [NEEDINFO]
[abrt] openstack-swift-container-1.8.0-2.fc19: socket.py:224:meth:error: [Err...
Status: CLOSED DUPLICATE of bug 947860
Product: Fedora
Classification: Fedora
Component: openstack-swift (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Pete Zaitcev
Fedora Extras Quality Assurance
abrt_hash:549b282164aaac20dede8d649b3...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-25 06:47 EDT by crisbud@redhat.com
Modified: 2014-06-18 03:47 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-14 15:56:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
zaitcev: needinfo? (crisbud)


Attachments (Terms of Use)
File: backtrace (904 bytes, text/plain)
2013-06-25 06:47 EDT, crisbud@redhat.com
no flags Details
File: core_backtrace (509 bytes, text/plain)
2013-06-25 06:47 EDT, crisbud@redhat.com
no flags Details
File: dso_list (105 bytes, text/plain)
2013-06-25 06:47 EDT, crisbud@redhat.com
no flags Details
File: environ (156 bytes, text/plain)
2013-06-25 06:47 EDT, crisbud@redhat.com
no flags Details

  None (edit)
Description crisbud@redhat.com 2013-06-25 06:47:16 EDT
Version-Release number of selected component:
openstack-swift-container-1.8.0-2.fc19

Additional info:
reporter:       libreport-2.1.5
cmdline:        /usr/bin/python /usr/bin/swift-container-server /etc/swift/container-server.conf
executable:     /usr/bin/swift-container-server
kernel:         3.9.6-200.fc18.x86_64
runlevel:       unknown
uid:            1001

Truncated backtrace:
socket.py:224:meth:error: [Errno 99] Cannot assign requested address

Traceback (most recent call last):
  File "/usr/bin/swift-container-server", line 22, in <module>
    run_wsgi(conf_file, 'container-server', default_port=6001, **options)
  File "/usr/lib/python2.7/site-packages/swift/common/wsgi.py", line 125, in run_wsgi
    sock = get_socket(conf, default_port=kwargs.get('default_port', 8080))
  File "/usr/lib/python2.7/site-packages/swift/common/wsgi.py", line 81, in get_socket
    family=address_family)
  File "/usr/lib/python2.7/site-packages/eventlet/convenience.py", line 38, in listen
    sock.bind(addr)
  File "/usr/lib64/python2.7/socket.py", line 224, in meth
    return getattr(self._sock,name)(*args)
error: [Errno 99] Cannot assign requested address

Local variables in innermost frame:
self: <socket._socketobject object at 0x20ab360>
args: (('10.70.1.93', 6001),)
name: 'bind'
Comment 1 crisbud@redhat.com 2013-06-25 06:47:23 EDT
Created attachment 765025 [details]
File: backtrace
Comment 2 crisbud@redhat.com 2013-06-25 06:47:29 EDT
Created attachment 765026 [details]
File: core_backtrace
Comment 3 crisbud@redhat.com 2013-06-25 06:47:34 EDT
Created attachment 765027 [details]
File: dso_list
Comment 4 crisbud@redhat.com 2013-06-25 06:47:39 EDT
Created attachment 765028 [details]
File: environ
Comment 5 Pete Zaitcev 2013-06-25 11:05:28 EDT
What's in `netstat -atpn| grep 6001'?

Probably it's X11, but with a twist this time: display #1, not #0!
Since ssh -Y usually starts higher, it may be something else.
Comment 6 Pete Zaitcev 2013-06-25 11:07:06 EDT
See also bug 947860, but please don't dup just yet.
Comment 7 Pete Zaitcev 2013-10-14 15:56:26 EDT

*** This bug has been marked as a duplicate of bug 947860 ***

Note You need to log in before you can comment on or make changes to this bug.