Bug 977822 - There is no option to install natives on HP-UX
There is no option to install natives on HP-UX
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Installer (Show other bugs)
6.1.1
Unspecified Unspecified
unspecified Severity urgent
: ---
: EAP 6.1.1
Assigned To: trev
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-25 08:19 EDT by Petr Kremensky
Modified: 2013-09-16 16:30 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
When running the text-based installer on Hewlett-Packard HP-UX with a 64-bit JVM, the native components were not offered as an installation option, preventing their installation by this method. The cause of the problem was that a reference to the HP-UX 64-bit native components was missing from one of the installer's configuration files. This issue has now been resolved and the text-based installer now offers the native components as an installation option when using either a 32-bit or 64-bit JVM.
Story Points: ---
Clone Of:
Environment:
HP-UX
Last Closed: 2013-09-16 16:30:28 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petr Kremensky 2013-06-25 08:19:17 EDT
Natives cannot be installed on HP-UX.
uname -a
HP-UX eph-02 B.11.31 U ia64 3721872372 unlimited-user license

...
Select the packs you want to install:
[JBoss Core] [Required]
        AppClient [y/n] 
        Bin [Required]
        Bundles [Required]
        XMLs and XSDs [y/n] 
        Domain [Required]
                Domain Shell Scripts [Required]
        Modules [Required]
        Standalone [Required]
                Standalone Shell Scripts [Required]
        Welcome Content [Required]
        Quickstarts [Already Selected]
        Icons [Required]
Pack Selection Done
...
Comment 2 Petr Kremensky 2013-06-25 10:45:18 EDT
Hi Jyoti, 
I tried it again and Natives are installed only for 32b jvm (I tried only 64b before). 

Running "java -jar -d64 jboss-eap-6.1.1.ER1-installer.jar" won't show me Natives option.
Comment 3 Jyoti Tripathi 2013-06-25 11:36:53 EDT
Thanks. You're right, it was not working on a 64b jvm. The next ER will have the fix.
Comment 4 Petr Kremensky 2013-07-08 09:43:41 EDT
Verified on EAP 6.1.1 ER2
Comment 5 Russell Dickenson 2013-07-31 21:15:31 EDT
It was agreed that for EAP 6.1.0 that the only installation method to be documented was the 'Zip' method. Since there are no instructions on the 'JAR' installation method, I don't know if this BZ ticket should be documented in the release notes.
Comment 6 Scott Mumford 2013-08-20 23:09:44 EDT
Resetting release notes flag to '?' as this still seems unanswered.
Comment 7 Russell Dickenson 2013-08-27 00:41:57 EDT
Attention: Jyoti

I have drafted a Release Notes entry for this issue but it is incomplete because the underlying cause of this issue is not specified. Just why were the native components not offered when the text-based installer was used together with a 62-bit JVM?
Comment 8 Petr Kremensky 2013-08-27 02:18:08 EDT
Hi Russell, 
Jyoti is in Red Hat no more. Changing need info to thauser who is in charge of installer.

Tom, can you please look into this? Thanks.

PR: http://git.app.eng.bos.redhat.com/?p=jbossas-installer.git;a=commit;h=5db36c308d0b9c0cb56e64b31389dff61568281e
Comment 9 Thomas Hauser 2013-08-27 09:38:05 EDT
Hello Russell,

The reason for this was that the installer repository was simply missing the declaration for the natives to be offered. 

<os name="HP-UX" arch="IA64N"/>
<os name="HP-UX" arch="IA64W"/>

The second line was missing from the installer's natives offering, so when using the 64bit JVM would not be displayed. This stemmed from a little unfamiliarity with HP-UX.

Hope this helps,
Tom
Comment 10 Russell Dickenson 2013-08-28 00:48:02 EDT
Tom,

Fantastic! Thankyou so much for filling in the blanks there.

Note You need to log in before you can comment on or make changes to this bug.