Bug 977831 - Missing equality index for ipaUniqueID
Missing equality index for ipaUniqueID
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ipa (Show other bugs)
7.0
Unspecified Unspecified
medium Severity unspecified
: rc
: ---
Assigned To: Martin Kosek
Namita Soman
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-25 08:46 EDT by Dmitri Pal
Modified: 2015-01-21 15:02 EST (History)
2 users (show)

See Also:
Fixed In Version: ipa-3.2.2-1.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-13 08:16:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dmitri Pal 2013-06-25 08:46:58 EDT
This bug is created as a clone of upstream ticket:
https://fedorahosted.org/freeipa/ticket/3743

IPA uses the attribute uniqueness plugin to look for unique values of ipaUniqueID when adding entries.

Because ipaUniqueID is not indexed, the server has to look through every single entry in the db.  ipaUniqueID needs to be indexed for equality to avoid this expensive lookup.
Comment 1 Martin Kosek 2013-07-16 11:50:08 EDT
Fixed upstream:

master: a209bb38aad66a079d62541e3b364d714cc3ed29
ipa-3-2: 6359b36290709f4bcbed22e913afb01c444727cf
Comment 3 Xiyang Dong 2013-08-19 10:25:41 EDT
Verified.

Version : ipa-server-3.2.2-1.el7.x86_64


Automated Test Results :

::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::
:: [   LOG    ] :: ipa-user-cli-mod-bugzilla-001:bz977831 Missing equality index for ipaUniqueID
::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::::

spawn /usr/bin/kinit -V admin
Using new cache: :/run/user/0/krb5cc/tktvdgrLO
Using principal: admin@TESTRELM.COM
Password for admin@TESTRELM.COM: 
Authenticated to Kerberos v5
Default principal: admin@TESTRELM.COM
:: [ 10:18:38 ] ::  kinit as admin with password Secret123 was successful.
:: [ 10:18:38 ] ::  Checking :ldapsearch -Y GSSAPI -b "cn=ldbm database,cn=plugins,cn=config" | grep ipauniqueid | grep index
SASL/GSSAPI authentication started
SASL username: admin@TESTRELM.COM
SASL SSF: 56
SASL data security layer installed.
# ipauniqueid, index, userRoot, ldbm database, plugins, config
dn: cn=ipauniqueid,cn=index,cn=userRoot,cn=ldbm database,cn=plugins,cn=config
:: [   PASS   ] :: make sure ipaUniqueID is indexed
Comment 4 Ludek Smid 2014-06-13 08:16:42 EDT
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.

Note You need to log in before you can comment on or make changes to this bug.