Bug 97784 - initscript has some flaws
initscript has some flaws
Status: CLOSED CURRENTRELEASE
Product: Red Hat Raw Hide
Classification: Retired
Component: vixie-cron (Show other bugs)
1.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jens Petersen
Brock Organ
:
Depends On:
Blocks: 170806
  Show dependency treegraph
 
Reported: 2003-06-20 18:09 EDT by Enrico Scholz
Modified: 2007-04-18 12:54 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-30 19:08:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Enrico Scholz 2003-06-20 18:09:29 EDT
Description of problem:

There are some flaws in /etc/init.d/crond:

1. reload() should use either 'retval' or 'RETVAL' but not both:
   | reload() {
   |      retval=$?
   |      ...
   |      return $RETVAL
   | }

2. The 'exit $?' at the end of the script is redundant since sh-scripts
   are returning always with the exit-code of the last command ($?)

3. The 'RETVAL=0' statement at the begin of the script does not has an
   effect since RETVAL is used inside of functions only



Version-Release number of selected component (if applicable):

vixie-cron-3.0.1-76
Comment 1 Jens Petersen 2004-06-30 12:31:51 EDT
Thanks, should get finally fixed in vixie-cron-3.0.1-94.
Comment 2 Jason Vas Dias 2004-08-30 19:08:21 EDT
This was fixed vixie-cron-3.0.1-94 & in latest version: vixie-cron-4.1-10.

Note You need to log in before you can comment on or make changes to this bug.