Bug 977858 - gnome classic has solid white wallpaper
gnome classic has solid white wallpaper
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: gnome-shell-extensions (Show other bugs)
19
All Linux
unspecified Severity low
: ---
: ---
Assigned To: Rahul Sundaram
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-25 09:20 EDT by Jeff Bastian
Modified: 2013-06-26 11:00 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-26 10:21:40 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
gnome classic with solid white wallpaper (251.21 KB, image/png)
2013-06-25 09:26 EDT, Jeff Bastian
no flags Details
gnome classic overview shows the correct wallpaper (1.72 MB, image/png)
2013-06-25 09:27 EDT, Jeff Bastian
no flags Details

  None (edit)
Description Jeff Bastian 2013-06-25 09:20:47 EDT
Description of problem:
The Gnome Classic session has a solid white wallpaper.  Choosing a new wallpaper from the Control Center has no effect.  However, opening the Overview shows the correct wallpaper!  But then returning to the application brings back the solid white wallpaper.

Version-Release number of selected component (if applicable):
gnome-classic-session-3.8.3-2.fc19.noarch
gnome-session-3.8.2.1-2.fc19.x86_64
gnome-shell-3.8.3-2.fc19.x86_64

How reproducible:
unknown

Steps to Reproduce:
1. login with Gnome Classic session

Actual results:
solid white background for wallpaper

Expected results:
normal wallpaper

Additional info:
I thought this was due to bug 975521 but I've updated my glib2 package and started with a fresh dconf database and the wallpaper is still white.
Comment 1 Jeff Bastian 2013-06-25 09:26:21 EDT
Created attachment 765090 [details]
gnome classic with solid white wallpaper
Comment 2 Jeff Bastian 2013-06-25 09:27:05 EDT
Created attachment 765092 [details]
gnome classic overview shows the correct wallpaper
Comment 3 Rahul Sundaram 2013-06-25 17:14:47 EDT
Please create a new user, login and check to make sure this isn't some local configuration issue.
Comment 4 Jeff Bastian 2013-06-26 10:21:40 EDT
Ok, it is a config issue with my account: the new user can change wallpaper just fine.

I'll report back if/when I discover the root cause.
Comment 5 Jeff Bastian 2013-06-26 11:00:16 EDT
The problem was I had created a symlink for gtk3 themes
  $HOME/.config/gtk-3.0 -> /usr/share/themes/Radiance/gtk-3.0

This was to make gtk3 apps like nm-applet and Gnome Boxes look nice under Xfce.  The Adwaita theme looks terrible under Xfce, see bug 963324

I guess I'll need to find a new workaround for gtk3 themes when switching between Xfce and Gnome and KDE...

Note You need to log in before you can comment on or make changes to this bug.