Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 977867 - Jcr2vfs migration tool fails to start with 'could not find or load main class ...libs.aether-api-1.13.1.jar'
Summary: Jcr2vfs migration tool fails to start with 'could not find or load main class...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss BRMS Platform 6
Classification: Retired
Component: Build and Assembly
Version: 6.0.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 6.0.0
Assignee: Julian Coleman
QA Contact: Petr Široký
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-06-25 13:43 UTC by Petr Široký
Modified: 2014-08-06 20:18 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-06 20:18:56 UTC
Type: Bug


Attachments (Terms of Use)

Description Petr Široký 2013-06-25 13:43:00 UTC
Description of problem:
Running the jcr2vfs migration tool results in the error "could not find or load main class ...libs.aether-api-1.13.1.jar".

Whole output: 
$ sh runMigration.sh
Usage: ./runMigration.sh
For example: ./runMigration.sh
Some notes:
- Working dir should be the directory of this script.
- Java is recommended to be JDK and java 6 for optimal performance
- The environment variable JAVA_HOME should be set to the JDK installation directory
  For example (linux): export JAVA_HOME=/usr/lib/jvm/java-6-sun
  For example (mac): export JAVA_HOME=/Library/Java/Home

Starting migration app...
Error: Could not find or load main class ...libs.aether-api-1.13.1.jar

Error occurred. Check if $JAVA_HOME (/usr/lib/jvm/java-1.7.0-openjdk-1.7.0.25.x86_64) is correct.



Version-Release number of selected component (if applicable):
6.0.0-DR5

How reproducible:
Always

Steps to Reproduce:
1. Get and unzip the jcr2vfs migratool.
2. Execute "sh runMigration.sh"

Actual results:
Above error displayed.

Expected results:


Additional info:

Comment 1 Petr Široký 2013-06-25 13:51:01 UTC
This issue is not appearing with latest community bits, so maybe it was fixed in mean time or the productization process introduced this error. I will wait for DR6 to see if the error is still present.

Comment 2 Petr Široký 2013-07-17 14:34:26 UTC
Closing as the issue is fixed in 6.0.0-DR6.


Note You need to log in before you can comment on or make changes to this bug.