Bug 977909 - Console package lays down files with Fedora in the name
Console package lays down files with Fedora in the name
Status: CLOSED ERRATA
Product: OpenShift Container Platform
Classification: Red Hat
Component: Website (Show other bugs)
1.2.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jason DeTiberus
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-25 11:01 EDT by Jason DeTiberus
Modified: 2017-03-08 12 EST (History)
3 users (show)

See Also:
Fixed In Version: openshift-origin-console-1.5.20-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-05 13:17:00 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jason DeTiberus 2013-06-25 11:01:44 EDT
Description of problem:
The openshift-origin-console package lays down a file with fedora in the name: Gemfile.fedora

Version-Release number of selected component (if applicable):


How reproducible:
Everytime

Steps to Reproduce:
1. Install RPM
2. ls -l /var/www/openshift/console/Gemfile.fedora
3. Profit

Actual results:
File exists

Expected results:
File does not exist

Additional info:
Upstream has fixed the gemfile issue, using just one Gemfile instead of 2 different ones and copying based on OS.  For OSE, just need to rm the Gemfile.fedora file after moving the Gemfile.rhel
Comment 2 Jason DeTiberus 2013-07-05 16:07:50 EDT
https://github.com/openshift/enterprise-server/pull/97
Comment 4 Yujie Zhang 2013-07-15 03:47:31 EDT
Tested on the puddle of 2013-07-15, there is no Gemfile.fedora in /var/www/openshift/console/ directory now, so verify this bug, thanks.
Comment 7 errata-xmlrpc 2013-08-05 13:17:00 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1138.html

Note You need to log in before you can comment on or make changes to this bug.