This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 977919 - Dangling symlink in openshift-origin-cartridge-perl package
Dangling symlink in openshift-origin-cartridge-perl package
Status: CLOSED ERRATA
Product: OpenShift Container Platform
Classification: Red Hat
Component: Containers (Show other bugs)
1.2.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Luke Meyer
libra bugs
:
Depends On: 977914
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-25 11:08 EDT by Jason DeTiberus
Modified: 2017-03-08 12 EST (History)
5 users (show)

See Also:
Fixed In Version: openshift-origin-cartridge-perl-0.4.8.1-1.el6op.noarch.rpm
Doc Type: Bug Fix
Doc Text:
The openshift-origin-cartridge-perl source code contained an unnecessary symlink with a missing target. This symlink was packaged into a broken symlink in the build. With this fix, the symlink has been removed from the source code and the broken symlink no longer appears.
Story Points: ---
Clone Of: 977914
Environment:
Last Closed: 2013-08-05 13:17:46 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jason DeTiberus 2013-06-25 11:08:51 EDT
+++ This bug was initially created as a clone of Bug #977914 +++

Description of problem:
openshift-origin-cartridge-perl has a dangling symlink: File usr/libexec/openshift/cartridges/v2/perl/versions/5.10/metadata is a dangling symlink (to ../shared/metadata/) on noarch

Version-Release number of selected component (if applicable):


How reproducible:
Every time

Steps to Reproduce:
1. Install package
2. ls -l usr/libexec/openshift/cartridges/v2/perl/versions/5.10/metadata

Actual results:
ls shows broken symlink

Expected results:
symlink should not exist

Additional info:
This looks to be left over from early v2 work where there was a versions/shared/metadata directory that no longer exists.
Comment 2 openshift-github-bot 2013-07-18 15:24:01 EDT
Commit pushed to master at https://github.com/openshift/origin-server

https://github.com/openshift/origin-server/commit/7e8d61fcb6b7cd8a541a318e01dbef7b0d8ace31
<ruby cart> bug 977919 remove broken symlinks
Comment 3 Luke Meyer 2013-07-18 15:47:12 EDT
Above comment is in error due to me mislabeling the commit. Actual fix is as follows:

https://github.com/openshift/enterprise-server/pull/110
Cherry-picking commit:
commit d46f3f13a2713900f18f82cceab51c7722df1d07
Author: Luke Meyer <lmeyer@redhat.com>
Date:   Thu Jul 18 14:25:42 2013 -0400

    <perl cart> bug 977914 remove broken symlinks
Comment 5 Gaoyun Pei 2013-07-22 03:01:50 EDT
Verify this on puddle 1.2/2013-07-19.1

[root@node ~]# ls -l usr/libexec/openshift/cartridges/v2/perl/versions/5.10/metadata
ls: cannot access usr/libexec/openshift/cartridges/v2/perl/versions/5.10/metadata: No such file or directory
[root@node ~]# cd /usr/libexec/openshift/cartridges/v2/perl/versions/5.10
[root@node 5.10]# ls -al
total 8
drwxr-xr-x. 2 root root 4096 Jul 21 17:54 .
drwxr-xr-x. 4 root root 4096 Jul 21 17:54 ..
lrwxrwxrwx. 1 root root   14 Jul 21 17:54 etc -> ../shared/etc/
Comment 8 errata-xmlrpc 2013-08-05 13:17:46 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1138.html

Note You need to log in before you can comment on or make changes to this bug.