Bug 977929 - broker-util scripts in need of manpages
broker-util scripts in need of manpages
Status: CLOSED CURRENTRELEASE
Product: OpenShift Online
Classification: Red Hat
Component: Pod (Show other bugs)
2.x
Unspecified Unspecified
unspecified Severity low
: ---
: ---
Assigned To: Lili Nader
libra bugs
:
: 1008563 (view as bug list)
Depends On: 973809
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-25 11:26 EDT by Jason DeTiberus
Modified: 2015-05-14 20:18 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 973809
Environment:
Last Closed: 2014-01-23 22:33:33 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jason DeTiberus 2013-06-25 11:26:43 EDT
+++ This bug was initially created as a clone of Bug #973809 +++

Description of problem:
oo-admin-clear-pending-ops is described internally but not documented for our users.

Expected results:
man oo-admin-clear-pending-ops should tell us how to use it and what it's for.
oo-admin-clear-pending-ops -h should tell us what it's for.

Might be a good idea to mention it in the Troubleshooting Guide too.

--- Additional comment from Jason DeTiberus on 2013-06-25 11:25:48 EDT ---

All broker-util scripts in need of manpages:
  /usr/sbin/oo-admin-clear-pending-ops
  /usr/sbin/oo-admin-ctl-authorization
  /usr/sbin/oo-analytics-export
  /usr/sbin/oo-analytics-import
Comment 1 Lili Nader 2013-11-04 18:54:38 EST
This has already been fixed by lmeyer
Comment 2 Luke Meyer 2013-11-06 00:15:32 EST
pending ops has a man page. Not the rest.

[root@broker ~]# man oo-admin-ctl-authorization
No manual entry for oo-admin-ctl-authorization
[root@broker ~]# man oo-analytics-export
No manual entry for oo-analytics-export
[root@broker ~]# man oo-analytics-import
No manual entry for oo-analytics-import
Comment 3 Abhishek Gupta 2013-11-13 12:50:16 EST
*** Bug 1008563 has been marked as a duplicate of this bug. ***
Comment 4 Brenton Leanhardt 2013-11-18 14:48:11 EST
The currently missing man pages for openshift-origin-broker-util are:

  /usr/sbin/oo-admin-ctl-authorization
  /usr/sbin/oo-admin-upgrade
  /usr/sbin/oo-analytics-export
  /usr/sbin/oo-analytics-import
  /usr/sbin/oo-quarantine
Comment 5 Lili Nader 2013-11-25 19:42:20 EST
Added for man pages for oo-admin-ctl-authorization, oo-analytics-export, oo-analytics-import

https://github.com/openshift/origin-server/pull/4251
Comment 6 Lili Nader 2013-11-25 19:43:27 EST
QE - please create separate bugs for the other scripts.  Otherwise this bug will never be resolved...if people keep adding to it.
Comment 7 Jianwei Hou 2013-11-26 01:05:10 EST
Opened bug 1034554 and bug 1034555 as separate issue tracker.
Comment 9 Jianwei Hou 2013-11-26 21:59:02 EST
Verified on devenv_4076
oo-admin-ctl-authorization, oo-analytics-export, oo-analytics-import now has man pages, the rest admin tools will be tracked separately.

Note You need to log in before you can comment on or make changes to this bug.