Bug 977941 - Cannot build simple program using Ruby binding without specifying path to arch dependent config.h
Cannot build simple program using Ruby binding without specifying path to arc...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: ruby (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jeroen van Meeuwen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-25 11:39 EDT by Vít Ondruch
Modified: 2013-07-15 21:36 EDT (History)
7 users (show)

See Also:
Fixed In Version: ruby-2.0.0.247-14.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-15 21:36:22 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Vít Ondruch 2013-06-25 11:39:05 EDT
This should work but it doesn't due to arch specific config.h, which is not accessible in default headers search path. See [1] for discussion of this issue.

$ cat > rt.c
#include "ruby.h"

int main(int argc, char **argv)
{
  return 0;
}
^D



$ gcc rt.c
In file included from /usr/include/ruby.h:33:0,
                 from rt.c:1:
/usr/include/ruby/ruby.h:24:25: fatal error: ruby/config.h: No such file or directory
 #include "ruby/config.h"
                         ^
compilation terminated.



[1] https://lists.fedoraproject.org/pipermail/devel/2013-June/184446.html
Comment 1 Fedora Update System 2013-07-02 08:17:20 EDT
ruby-2.0.0.247-11.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/FEDORA-2013-12118/ruby-2.0.0.247-11.fc19
Comment 2 Fedora Update System 2013-07-02 21:44:42 EDT
Package ruby-2.0.0.247-11.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing ruby-2.0.0.247-11.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-12118/ruby-2.0.0.247-11.fc19
then log in and leave karma (feedback).
Comment 3 Fedora Update System 2013-07-09 07:07:37 EDT
ruby-2.0.0.247-12.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/ruby-2.0.0.247-12.fc19
Comment 4 Fedora Update System 2013-07-15 21:36:22 EDT
ruby-2.0.0.247-14.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.