Bug 977943 - [ovirt-guest-agent] - init script - condrestart should use param '-s' instead '-f'
[ovirt-guest-agent] - init script - condrestart should use param '-s' instead...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-guest-agent (Show other bugs)
3.2.0
Unspecified Linux
high Severity medium
: ---
: 3.3.0
Assigned To: Vinzenz Feenstra [evilissimo]
Jiri Belka
virt
:
Depends On:
Blocks: 1019461
  Show dependency treegraph
 
Reported: 2013-06-25 11:41 EDT by Pavel Stehlik
Modified: 2015-09-22 09 EDT (History)
6 users (show)

See Also:
Fixed In Version: is11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 16565 None None None Never

  None (edit)
Description Pavel Stehlik 2013-06-25 11:41:13 EDT
Description of problem:
 Our TPSs fail due to 'condrestart' of agent on physical machine is checking .pid file with '-f' (FILE exists and is a regular file) instead of '-s' (FILE exists and has a size greater than zero).
The .pid file is present even service is not able to run successfully. It's empty.
In case customer will install & try run agent on machine which doesn't posses virtio channel & then he will update agent - he ends with installation of 2 packages.
(eg: rhevm-guest-agent-1.0.7-8.el5 & rhevm-guest-agent-1.0.7-9.el5ev).


Version-Release number of selected component (if applicable):
rhevm-guest-agent-1.0.7-9.el5ev
rhevm-guest-agent-1.0.7-12.el6ev

How reproducible:
100%

Steps to Reproduce:
1. install agent, try to start daemon
2. yum update rhevm-guest-agent
3.

Actual results:
error: %postun(rhevm-guest-agent-1.0.7-8.el5.noarch) scriptlet failed, exit status 1

Expected results:


Additional info:


/etc/init.d/ovirt-guest-agent :
...
   condrestart)
        if [ -f ${pidfile} ] ; then


this leads to postuninstall issue:

error: %postun(rhevm-guest-agent-1.0.7-8.el5.noarch) scriptlet failed, exit status 1

because (RPM post-uninstall script):
...
if [ "$1" -ge 1 ]; then
    /sbin/service ovirt-guest-agent condrestart > /dev/null 2>&1
Comment 1 Vinzenz Feenstra [evilissimo] 2013-08-12 08:59:41 EDT
Merged u/s to master: http://gerrit.ovirt.org/gitweb?p=ovirt-guest-agent.git;a=commit;h=1ad924dfec7344edb8540544518d60117429800e
Comment 2 Jiri Belka 2013-09-11 08:14:36 EDT
ok, is13.
Comment 3 Itamar Heim 2014-01-21 17:24:04 EST
Closing - RHEV 3.3 Released
Comment 4 Itamar Heim 2014-01-21 17:25:05 EST
Closing - RHEV 3.3 Released
Comment 5 Itamar Heim 2014-01-21 17:28:39 EST
Closing - RHEV 3.3 Released

Note You need to log in before you can comment on or make changes to this bug.