Bug 977950 - Frameworks list in cartridge description is incorrect for Python and Perl
Frameworks list in cartridge description is incorrect for Python and Perl
Status: CLOSED CURRENTRELEASE
Product: OpenShift Online
Classification: Red Hat
Component: Containers (Show other bugs)
2.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Rob Millner
libra bugs
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-25 12:16 EDT by Nam Duong
Modified: 2015-05-14 19:22 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-22 11:18:15 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nam Duong 2013-06-25 12:16:18 EDT
Description of problem:
This was reported by our users.  See:
https://openshift.redhat.com/app/console/application_types?tag=python  
https://openshift.redhat.com/app/console/application_types?tag=perl  

The frameworks list is just wrong.  See https://www.openshift.com/developers/python and https://www.openshift.com/developers/perl for examples.
Comment 1 Clayton Coleman 2013-06-26 14:06:15 EDT
That's not a list of frameworks - it's a list of quickstarts and cartridges available in OpenShift.
Comment 2 Clayton Coleman 2013-06-26 15:24:09 EDT
The description field in the cartridge metadata for Python and Perl is incorrect and was broken.  I believe this was correct at one point and got reverted.

This should be fixed ASAP since it's a regression.
Comment 3 Nam Duong 2013-06-26 15:32:48 EDT
My fault on the obscure bug report with links rather than specifics.  Here are the specifics:  

This is feedback from a user about confusion in the cartridge description.  It currently states:  
"Python is a general-purpose server-side scripting language originally designed for Web development to produce dynamic Web pages. Popular development frameworks include: CakePython, Zend, Symfony, and Code Igniter."

The part about popular frameworks for Python is wrong.  User's exact statement:  

"You may wish to review the descriptions you have for the Python containers as found here:

https://openshift.redhat.com/app/console/application_types?tag=python

It states that "Popular development frameworks include: CakePython, Zend, Symfony, and Code Igniter." As I'm sure you're aware, this is not an accurate statement.
"

Thanks for considering a fix/update to the description.
Comment 4 Rob Millner 2013-06-27 15:44:17 EDT
I'm going to use the v1 cartridge descriptions for these cartridges.  What got in v2 seems to be incorrect.

Perl:

"Perl is a high-level, general-purpose, interpreted, dynamic programming language. Dynamic content produced by Perl scripts can be served in response to incoming web requests."

Python:

"Python is a general-purpose, high-level programming language whose design philosophy emphasizes code readability. Popular development frameworks include: Django, Bottle, Pylons, Zope and TurboGears."
Comment 5 Rob Millner 2013-06-27 16:00:53 EDT
Master pull request:
https://github.com/openshift/origin-server/pull/2955
Comment 6 Rob Millner 2013-06-27 16:03:59 EDT
Stage pull request:
https://github.com/openshift/origin-server/pull/2956
Comment 7 openshift-github-bot 2013-06-27 18:04:39 EDT
Commit pushed to master at https://github.com/openshift/origin-server

https://github.com/openshift/origin-server/commit/4fa2934660577b6b24925ab01c52dba1694d6f9c
Bug 977950 - Copying the v1 descriptions back into the v2 versions of the cartridge.
Comment 8 Meng Bo 2013-06-28 04:29:31 EDT
Checked on current stage (devenv-stage_382), issue fixed.

The python and perl has the correct description in the create app page.

Note You need to log in before you can comment on or make changes to this bug.