Bug 977983 - Failed to install libcgroup because base package is newer than package in Node puddle repo
Failed to install libcgroup because base package is newer than package in Nod...
Status: CLOSED CURRENTRELEASE
Product: OpenShift Container Platform
Classification: Red Hat
Component: Containers (Show other bugs)
1.2.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jason DeTiberus
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-25 14:01 EDT by Chris Murphy
Modified: 2017-03-08 12 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-28 11:47:24 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Murphy 2013-06-25 14:01:43 EDT
Description of problem:
Install of node from openshift-amz.sh script errors on multilib version protection

Version-Release number of selected component (if applicable):
1.2.1 - 2013-06-21.2

How reproducible:
Always

Steps to Reproduce:
1.yum install openshift-origin-msg-node-mcollective
2.
3.

Actual results:

Protected multilib versions: libcgroup-0.37-7.1.el6_4.i686 != libcgroup-0.37-7.2.el6_4.x86_64

Expected results:
Yum is able to find matching multilib dependency version for libcgroup

Additional info:
libcgroup-0.37-7.2.el6_4.x86_64 gets installed from the base channel, however the i686 version is missing from the "node" repo. The "node" repo only has libcgroup-0.37-7.1.el6_4.i686 available
 
libcgroup-0.37-7.2.el6_4.x86_64 : Tools and libraries to control and monitor control groups
Repo        : installed
Matched from:
Other       : Provides-match: libcgroup
Comment 2 Jason DeTiberus 2013-06-25 16:19:41 EDT
This package has been added to the latest dev puddle: buildvm-devops.usersys.redhat.com/puddle/build/OpenShiftEnterprise/1.2/2013-06-25.1/
and the latest RC puddle: http://download.lab.bos.redhat.com/rel-eng/OpenShiftEnterprise/1.2/2013-06-25.3/

And by the way, at this time, our standard RHEL install source:
http://cdn.rcm-qa.redhat.com/content/dist/rhel/server/6/6Server/x86_64/os/Packages/
... does not have the updated libcgroup, as it is about a day behind, so for a while our 1.2 test installs will fail. You could pull the updated version from brew and
+pre-install on any nodes:
http://download.devel.redhat.com/brewroot/packages/libcgroup/0.37/7.2.el6_4/x86_64/libcgroup-0.37-7.2.el6_4.x86_64.rpm

Public RHN and RHSM channels appear to have the update.
Comment 3 Johnny Liu 2013-06-27 04:03:51 EDT
Currently libcgroup-0.37-7.2.el6_4.x86_64.rpm is already pushed to Public RHN, but RHSM channels still does not have this update, maybe have some delay.

Update libcgroup to the latest version (libcgroup-0.37-7.2.el6_4.x86_64.rpm), use 1.2/2013-06-21.2 puddle to install openshift-origin-msg-node-mcollective, this issue is reproduced.

Replace node repo to http://buildvm-devops.usersys.redhat.com/puddle/build/OpenShiftEnterprise/1.2/2013-06-26.3/Node/x86_64/os/ or http://download.lab.bos.redhat.com/rel-eng/OpenShiftEnterprise/1.2/2013-06-26.3/Node/x86_64/os/, this issue is disappeared, that is because libcgroup-pam-0.37-7.1.el6_4 is already replaced by libcgroup-pam-0.37-7.2.el6_4 in the node repo. so dependency issue is fixed now.
Comment 4 Luke Meyer 2013-06-28 11:47:24 EDT
Closing all bugs introduced, fixed, and verified during 1.2 release work (thus never shipped).

Note You need to log in before you can comment on or make changes to this bug.