Bug 978079 - wine will not install on F19-RC1 64 bit due to Multilib version problem
wine will not install on F19-RC1 64 bit due to Multilib version problem
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: wine (Show other bugs)
19
All Linux
unspecified Severity medium
: ---
: ---
Assigned To: Andreas Bierfert
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-25 19:54 EDT by Ed Greshko
Modified: 2013-06-26 00:21 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-26 00:21:05 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ed Greshko 2013-06-25 19:54:47 EDT
Description of problem:  wine will not install on F19-RC1 64 bit due to Multilib version problem


Version-Release number of selected component (if applicable):


How reproducible:  Install F19-64bit, RC1 and then "yum install wine"


Steps to Reproduce:
1.
2.
3.

Actual results:

--> Finished Dependency Resolution
Error:  Multilib version problems found. This often means that the root
       cause is something else and multilib version checking is just
       pointing out that there is a problem. Eg.:
       
         1. You have an upgrade for harfbuzz which is missing some
            dependency that another package requires. Yum is trying to
            solve this by installing an older version of harfbuzz of the
            different architecture. If you exclude the bad architecture
            yum will tell you what the root cause is (which package
            requires what). You can try redoing the upgrade with
            --exclude harfbuzz.otherarch ... this should give you an error
            message showing the root cause of the problem.
       
         2. You have multiple architectures of harfbuzz installed, but
            yum can only see an upgrade for one of those architectures.
            If you don't want/need both architectures anymore then you
            can remove the one with the missing update and everything
            will work.
       
         3. You have duplicate versions of harfbuzz installed already.
            You can use "yum check" to get yum show these errors.
       
       ...you can also use --setopt=protected_multilib=false to remove
       this checking, however this is almost never the correct thing to
       do as something else is very likely to go wrong (often causing
       much more problems).
       
       Protected multilib versions: harfbuzz-0.9.18-2.fc19.i686 != harfbuzz-0.9.18-3.fc19.x86_64


Expected results:  I think it should complete


Additional info:   I don't use wine myself.  I just filed this bug due to curiosity after reading a post to the "testing" mailing list.  :-)
Comment 1 Ed Greshko 2013-06-26 00:21:05 EDT
yum distro-sync resolved the problem....  Hadn't though of that since I thought an RCX would be "complete".  Thanks to rdieter@math.unl.edu

Note You need to log in before you can comment on or make changes to this bug.