Bug 978088 - Spell checking no longer works in Chrome on initial load
Spell checking no longer works in Chrome on initial load
Status: CLOSED CURRENTRELEASE
Product: PressGang CCMS
Classification: Community
Component: Web-UI (Show other bugs)
1.1
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Matthew Casperson
:
: 979196 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-25 20:30 EDT by Lee Newson
Modified: 2014-08-04 18:27 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-08 20:00:38 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lee Newson 2013-06-25 20:30:57 EDT
Since the change to using web workers for the spell checking, it no longer works in Chrome and fails with the following error:

Uncaught TypeError: Cannot call method 'check' of undefined :8080/pressgang-ccms-ui-next/javascript/typojs/checkspelling.js:179
Comment 1 Lee Newson 2013-06-25 20:36:20 EDT
Just found another interesting part, it only appears to fail when the page is initially loaded. If you do a search or go to a topic directly and then click the topic in the search results pane, the spell checking will start to work.
Comment 2 Lee Newson 2013-06-27 18:50:32 EDT
*** Bug 979196 has been marked as a duplicate of this bug. ***
Comment 3 Matthew Casperson 2013-06-30 21:21:23 EDT
The issue appears to be because the editor is only waiting for the positive dictionary to load, and is not waiting for the negative or negative phrase dictionaries to load.
Comment 4 Matthew Casperson 2013-06-30 21:25:48 EDT
Fixed in 201307011121

NOTE:
When QAing bug fixes, please make sure the build you are using is equal to or higher than the build identified above. Be aware that this fix may have only been applied in PressGang Next at this time, or it may not be currently applied in any production system, in which case it can only be verified at a later date.
Comment 5 Lee Newson 2013-06-30 22:45:28 EDT
The issue still remains in Build 201307011121. This is testing in Incognito mode and completely clearing my cache.

Also changing the title to be more descriptive.
Comment 6 Lee Newson 2013-06-30 23:19:38 EDT
Just adding additional details.

Now the spell checking fails earlier by the looks of it. The error is now:

Uncaught ReferenceError: console is not defined :8080/pressgang-ccms-ui/javascript/typojs/checkspelling.js:41

By the looks of it the spell checking is running in a web worker, in which case it doesn't have access to the console object (see: http://stackoverflow.com/questions/7251779/web-worker-console-log or http://www.htmlgoodies.com/html5/client/introduction-to-html5-web-workers-browser-support-non-accessible-elements-and-error-handling.html)
Comment 7 Lee Newson 2013-06-30 23:48:25 EDT
Forgot to mention, that the main problem is that the dictionary is still null.
Comment 8 Matthew Casperson 2013-07-16 20:39:29 EDT
Fixed in 201307171035

This was an issue with the sequence in which the dictionary data was passed to the worker.
Comment 9 Lee Newson 2013-07-17 00:04:40 EDT
Verified, so setting this to RELEASE_PENDING.

Note You need to log in before you can comment on or make changes to this bug.