Bug 978143 - [Docs] [Feature] - RFE: live snapshot with cpu/memory/disk status
[Docs] [Feature] - RFE: live snapshot with cpu/memory/disk status
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: Documentation (Show other bugs)
3.4.0
All Linux
medium Severity medium
: ---
: 3.3.0
Assigned To: Zac Dover
Laura Novich
http://www.ovirt.org/Features/RAM_Sna...
virt
: FutureFeature
Depends On: 960931 970559 976625
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-26 00:17 EDT by Tim Hildred
Modified: 2016-01-26 20:59 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of: 976625
Environment:
Last Closed: 2014-07-22 11:46:51 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 14053 None None None Never
oVirt gerrit 14167 None None None Never
oVirt gerrit 14201 None None None Never
oVirt gerrit 14290 None None None Never
oVirt gerrit 15072 None None None Never
oVirt gerrit 15608 None None None Never
oVirt gerrit 15678 None None None Never
oVirt gerrit 15679 None None None Never
oVirt gerrit 15681 None None None Never
oVirt gerrit 15682 None None None Never
oVirt gerrit 15683 None None None Never
oVirt gerrit 15684 None None None Never
oVirt gerrit 15685 None None None Never
oVirt gerrit 15686 None None None Never
oVirt gerrit 15687 None None None Never
oVirt gerrit 56810 None None None Never

  None (edit)
Comment 1 Tim Hildred 2013-07-30 03:26:59 EDT
The addition of this content changes the nature of the snapshots section overall. Whereas until now, snapshots fit nicely within the "Storage arch" chapter of the Technical Reference Guide, this additional information will break the neat categorization alongside storage.

To resolve this bug, we'll move the snapshots information out of "Storage Architecture" into its own chapter called "Virtual Machine Snapshots". It'll go after "Templates and pools".

The existing topics are appropriately named, but will need re-factoring to take the focus off of the storage implications of snapshots, and include the implications for CPU and memory with the same weight.
Comment 2 Tim Hildred 2013-08-05 22:33:50 EDT
Federico,

Do you agree with what I've said in comment #1?

Will you be willing to work with me to update the Technical Reference Guide Snapshots content as stated above, to help me make sure the implications of this PRD are reflected properly?
Comment 3 Ayal Baron 2013-09-04 01:30:18 EDT
Please note that in a *future* version we will have single disk snapshots, so you will need a snapshots section in the storage part.  However, snapshots today are indeed entire VM snapshots and not limited to storage.
The new feature adds persistence to the ram of the machine as well.

Michal can provide more info on this feature.
Comment 4 Michal Skrivanek 2013-09-04 03:36:52 EDT
Tim, I think for 3.3 it makes sense as you suggested to move it out. Please feel free to ask Arik Hadas or myself regarding implementation/behavioral details
Comment 5 Tim Hildred 2013-09-26 23:21:40 EDT
I've made the structural change, moving the snapshots content into it's own chapter.

Now I'll set up a meeting with Michal as soon as possible to discuss how we can update the existing content to more accurately reflect changes introduced in the 3.3 cycle.
Comment 6 Tim Hildred 2013-10-27 20:04:43 EDT
Reassigning to Jodi Biddle (jbiddle@redhat.com) as I am no longer working on Red Hat Enterprise Virtualization documentation.
Comment 8 Zac Dover 2014-07-22 11:46:51 EDT
Documentation Link
------------------
https://documentation-devel.engineering.redhat.com/site/documentation/en-US/Red_Hat_Enterprise_Virtualization/3.4/html-single/Administration_Guide/index.html#Creating_a_snapshot_of_a_virtual_machine

NVR
---
Red_Hat_Enterprise_Virtualization-Administration_Guide-3.4-en-US-3.4-31

What Changed
------------
Nothing, since the last time I touched the bug. An image of the "Disks to include" checkboxes are present in the RHEV 3.4 Administration guide.

I am closing this bug CLOSED CURRENTRELEASE.

Note You need to log in before you can comment on or make changes to this bug.