Bug 97819 - Can samba be build with winbind challenge support please
Can samba be build with winbind challenge support please
Status: CLOSED UPSTREAM
Product: Red Hat Raw Hide
Classification: Retired
Component: samba (Show other bugs)
1.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jay Fenlason
David Lawrence
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-06-22 05:09 EDT by Reuben Farrelly
Modified: 2014-08-31 19:25 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-15 06:56:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Reuben Farrelly 2003-06-22 05:09:32 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)

Description of problem:
Can samba be built with the additional config options of:

        --with-winbind
        --with-winbind-auth-challenge (needed for ntlm)

Thinking maybe '--with-winbind' is unnecessary but certainly the auth-
challenge statement is.  The reason I am asking is that being built with the 
additional options above makes it easier to integrate samba/winbind with squid 
to do NTLM authentication from within Squid proxy.  Otherwise we have to 
rebuild samba with the required build options for this to work.

See http://www.squid-cache.org/Doc/FAQ/FAQ-23.html#ss23.5 for more information 
on how this is done.

Version-Release number of selected component (if applicable):
Latest in rawhide - 2.2.8a-2.10

How reproducible:
Always

Steps to Reproduce:
1. N/A
2.
3.
    

Additional info:
Comment 1 Reuben Farrelly 2004-11-15 06:56:06 EST
It looks like winbind support is now in samba-3, (on Linux it is
automatically enabled unless explicitly turned off, apparently).  We
have /usr/lib/libnss_winbind.so and similar friends, so it's pretty
safe to assume it's all there.

Closing this bug, believed to be resolved.

Note You need to log in before you can comment on or make changes to this bug.