This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 978245 - install a rhel5 as kvm guest better always build initrd.img with ahci driver(and virtio-blk)
install a rhel5 as kvm guest better always build initrd.img with ahci driver(...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: mkinitrd (Show other bugs)
5.10
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Brian Lane
Release Test Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-26 03:35 EDT by Xiaoqing Wei
Modified: 2014-09-23 22:26 EDT (History)
11 users (show)

See Also:
Fixed In Version: mkinitrd-5.1.19.6-82
Doc Type: Bug Fix
Doc Text:
Prior to this update, the Advanced Host Controller Interface (AHCI) driver was not included in the initrd.img file. As a consequence, a Red Hat Enterprise Linux 5 guest in some cases failed to boot on a Red Hat Enterprise Linux 7 hypervisor. With this update, installing Red Hat Enterprise Linux 5 as a guest now always includes the AHCI driver, and the guest is therefore able to boot as expected.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-09-15 20:23:46 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Xiaoqing Wei 2013-06-26 03:35:51 EDT
Description of problem:

install a rhel5 as kvm guest better always build initrd.img with ahci driver

Version-Release number of selected component (if applicable):
rhel5.9 GA iso

How reproducible:
100%

Steps to Reproduce:
1.install a rhel5 as kvm guest on rhel7 hypervisor, using ide drive(without -device ahci)
2.boot guest with -device ahci would fail
3.

Actual results:
guest fails to boot, as the initrd.img in guest doesn't have ahci driver.

Expected results:
ahci driver should be included in the guest initrd.img, like virtio-blk
when install a rhel5 as kvm guest with ide controller, it will always include virtio-* drivers in initrd.img.

Additional info:

as RHEL.7 hypervisor would support ahci as drive controller,
and RHEL.5 would continue to be supported for a very long time,
and switching block device controller in a virt environment is quite common useage,
so better always include ahci driver at the installation stage, like virtio-* .
Comment 1 Xiaoqing Wei 2013-07-09 04:51:10 EDT
Hi Ronen,

could you pls tell

is installing a rhel5 with ide and boot it with ahci controller a supported way ?

Thanks,
Xiaoqing.
Comment 3 RHEL Product and Program Management 2014-01-22 11:30:38 EST
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 5 Alexander Todorov 2014-04-16 07:33:03 EDT
Tested with the latest RHEL 5.11 tree 


* Install 5.11 as KVM guest on latest RHEL 7 nightly hypervisor:

Results:
- both ahci.ko and virtio_blk.ko are included in the initrd
- virt-manager uses virtio by default
- after stopping the VM, changing the default disk bus from virtio to IDE and restarting: the VM was able to boot, disk is now /dev/hda instead of /dev/vda


* Install 5.11 as KVM guest on latest RHEL 5.11 nightly hypervisor

Results:
- both ahci.ko and virtio_blk.ko are included in the initrd
- virt-manager uses virtio by default
Comment 7 errata-xmlrpc 2014-09-15 20:23:46 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1224.html

Note You need to log in before you can comment on or make changes to this bug.