Bug 97825 - netcfg crashed on edit Hosts
netcfg crashed on edit Hosts
Status: CLOSED DUPLICATE of bug 80621
Product: Red Hat Linux
Classification: Retired
Component: redhat-config-network (Show other bugs)
9
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-06-22 12:31 EDT by jmw
Modified: 2007-04-18 12:54 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:56:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description jmw 2003-06-22 12:31:03 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.0.2)
Gecko/20030208 Netscape/7.02

Description of problem:
i was looking for a way to assign a host name to the machine.  i found i could
get to the Network Configuration GUI through "System Tools - Network Device
Control - Configure" or "System Settings - Network" and select the Hosts tab.

my home network has no DNS, but does have a Linksys DSL router with built-in
DHCP service, and the Linksys router assigns IP addresses.  as an experiment, i
had earlier added the LinkSys router fixed address under Hosts in the
configurator tool.  this time, "Hosts" shows that address listed twice.  i
deleted each, the configurator crashed, and a dump file was generated.  i opened
an Xterm window, and edited /etc/hosts to remove both references to the LinkSys
IP address.  i rebooted, reactivated the ethernet card, now everything is
restored.  

after the crash, SMB would start normally, but NMBD would not.  after the reboot
and reactivate, both SMB and NMBD appear to work normally.

Version-Release number of selected component (if applicable):


How reproducible:
Didn't try

Steps to Reproduce:
1. see above, under 'description'.
2.
3.
    

Additional info:

Component: redhat-config-network
Version: 1.2.0
Summary: TB /usr/lib/python2.2/site-packages/rhpl/Conf.py:473:__delitem__:KeyError
Traceback (most recent call last):
  File
"/usr/src/build/226257-noarch/install/usr/share/redhat-config-network/netconfpkg/gui/maindialog.py",
line 579, in on_applyButton_clicked
  File
"/usr/src/build/226257-noarch/install/usr/share/redhat-config-network/netconfpkg/gui/maindialog.py",
line 291, in save
  File
"/usr/src/build/226257-noarch/install/usr/share/redhat-config-network/netconfpkg/gui/maindialog.py",
line 324, in saveProfiles
  File
"/usr/src/build/226257-noarch/install/usr/share/redhat-config-network/netconfpkg/NCProfileList.py",
line 349, in save
  File "/usr/lib/python2.2/site-packages/rhpl/Conf.py", line 473, in __delitem__
    del self.vars[varname]
KeyError

Local variables in innermost frame:
varname: 
self: <rhpl.Conf.ConfEHosts instance at 0x8654e7c>
Comment 1 Harald Hoyer 2004-09-21 08:05:34 EDT
An errata has been issued which should help the problem described in
this bug report. 
This report is therefore being closed with a resolution of ERRATA. For
more information
on the solution and/or where to find the updated files, please follow
the link below. You may reopen 
this bug report if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2003-183.html



*** This bug has been marked as a duplicate of 80621 ***
Comment 2 Red Hat Bugzilla 2006-02-21 13:56:49 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.