Bug 978262 - Conflict between ast-devel and libast-devel
Conflict between ast-devel and libast-devel
Product: Fedora
Classification: Fedora
Component: ast (Show other bugs)
Unspecified Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Orion Poplawski
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2013-06-26 04:29 EDT by Walter Mueller
Modified: 2013-08-22 20:35 EDT (History)
2 users (show)

See Also:
Fixed In Version: ast-6.0.1-6.fc18
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2013-08-22 20:35:15 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Walter Mueller 2013-06-26 04:29:07 EDT
Description of problem:

Version-Release number of selected component (if applicable):

How reproducible:
Try to install both packages 

Steps to Reproduce:
1. install ast-devel
2. install libast-devel

Actual results:
file /usr/lib64/libast.so from install of libast-devel-0.7.1-0.12.20080502cvs.fc18.x86_64 conflicts with file from package ast-devel-6.0.1-3.fc18.x86_64

Expected results:
No conflict, both packages should be installeld

Additional info:
libast is needed for eterm-0.9.6-7.fc18.
Comment 1 Terje Røsten 2013-06-26 04:55:41 EDT
Hmm, Orion any suggestions to resolve this?
Comment 2 Orion Poplawski 2013-08-09 19:06:59 EDT

Move the libast* libraries into %{_libdir}/ast/ and add an ld.so.conf.d file.
Comment 3 Terje Røsten 2013-08-11 11:45:58 EDT
Should libast (current component) or ast move files (or both)?
Comment 4 Orion Poplawski 2013-08-11 11:51:14 EDT
Actually, I belive ast should change (more libraries, newer Fedora package).
Comment 5 Terje Røsten 2013-08-11 11:54:15 EDT
Ok, thanks!
Comment 6 Fedora Update System 2013-08-12 11:19:26 EDT
ast-6.0.1-6.fc18 has been submitted as an update for Fedora 18.
Comment 7 Fedora Update System 2013-08-14 23:06:15 EDT
Package ast-6.0.1-6.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing ast-6.0.1-6.fc18'
as soon as you are able to.
Please go to the following url:
then log in and leave karma (feedback).
Comment 8 Fedora Update System 2013-08-22 20:35:15 EDT
ast-6.0.1-6.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.