Bug 978288 - "[error] config web.product_name not in master config list in PXT::Config at /usr/share/perl5/vendor_perl/PXT/Config.pm line 164." when accessing *.pxt page
"[error] config web.product_name not in master config list in PXT::Config at ...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Server (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tomáš Kašpárek
Martin Korbel
:
Depends On:
Blocks: sat560-lowbug
  Show dependency treegraph
 
Reported: 2013-06-26 05:29 EDT by Jan Hutař
Modified: 2013-10-01 17:54 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-01 17:54:53 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Hutař 2013-06-26 05:29:19 EDT
Description of problem:
When you access Perl page there is a error generated (one or two) into error_log.


Version-Release number of selected component (if applicable):
Satellite-5.6.0-RHEL6-re20130620.0-x86_64
spacewalk-html-1.9.22-16.el6sat.noarch


How reproducible:
always


Steps to Reproduce:
1. WebUI: Systems -> System Set Manager -> Schedule errata updates
2. # tail /var/log/httpd/error_log


Actual results:
[Wed Jun 26 05:19:42 2013] [error] config web.product_name not in master config list in PXT::Config at /usr/share/perl5/vendor_perl/PXT/Config.pm line 164.


Expected results:
No such error there.


Additional info:
This happens on current SWnightly as well:
[error] config web.product_name not in master config list in PXT::Config at /usr/share/perl5/vendor_perl/PXT/Config.pm line 159.
Comment 1 Tomáš Kašpárek 2013-07-01 05:44:01 EDT
this issue was caused by 3305909fa254396f981ce3787d27569310110796 in spacewalk git
Comment 2 Tomáš Kašpárek 2013-07-01 07:56:40 EDT
fixed in spacewalk.git: d358dbcd812053f705aa2205033b3bb20861d554
Comment 4 Martin Korbel 2013-09-24 01:46:01 EDT
VERIFIED on spacewalk-web-2.0.3-16.el6sat

I have no chance to reproduce, because this compose is out of date and it is deleted. I have tested on Sat 5.5.0  and Satellite-5.6.0-RHEL6-re20130917
Comment 5 Clifford Perry 2013-10-01 17:54:53 EDT
Satellite 5.6 has been released. This bug was tracked under the release.  

This bug was either VERIFIED or RELEASE_PENDING (re-verified prior shortly
before release). 

Moving to CLOSED CURRENT_RELEASE. 

Text from Upgrade Erratum follows:

Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1395.html

Note You need to log in before you can comment on or make changes to this bug.