Bug 978301 - duplicate entries in custom partitioning
duplicate entries in custom partitioning
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-26 06:12 EDT by Branko Grubić
Modified: 2014-12-09 09:37 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-12-09 09:37:59 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot with multiple entries in the list (72.69 KB, image/png)
2013-06-26 06:12 EDT, Branko Grubić
no flags Details
sshot0 (83.66 KB, image/png)
2014-02-22 12:08 EST, Branko Grubić
no flags Details
sshot1 (73.69 KB, image/png)
2014-02-22 12:08 EST, Branko Grubić
no flags Details
sshot2 (78.67 KB, image/png)
2014-02-22 12:09 EST, Branko Grubić
no flags Details
anaconda.log (98.61 KB, text/plain)
2014-02-22 12:10 EST, Branko Grubić
no flags Details
program.log (25.64 KB, text/plain)
2014-02-22 12:11 EST, Branko Grubić
no flags Details
storage.log (108.16 KB, text/plain)
2014-02-22 12:12 EST, Branko Grubić
no flags Details

  None (edit)
Description Branko Grubić 2013-06-26 06:12:19 EDT
Created attachment 765504 [details]
screenshot with multiple entries in the list

Description of problem:
Testing F19 RC2, with custom partitioning I wanted to save my current partition layout (sda1 (/boot), sda2 (LUKS(LVM(swap,/home,/root))), and I set mount points, and checked format for every partition, and I wanted to change my settings to save (not reformat) my /home partition, it was accepted, and I unchecked "Reformat", moved to another entry, it applied but removed already set "Mount Point: /home" to empty field (another bug???), so I typed it again "/home" and moved to another entry, it applied my settings and created second "/home" entry in partition list "New Fedora 19 Installation". After this I tried it again, and playing with "Reformat" check/uncheck (it unsets "Mount Point:" (another bug???) and setting new mount point again creates new entry in the list 3. later I played with this and created multiple entries (copies). I didn't tested how it will affect installation, it looks like all copies have same settings (If I change one it affects others).


Maybe this happens if other settings are changed, but I didn't tested them!!!

Version-Release number of selected component (if applicable):
anaconda-19.30.12-1.fc19 (F19 RC2) 

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:
Changing partition settings (or some settings), creates multiple entries in new installation list

Expected results:
Changing partition settings (or some settings), doesn't creates multiple entries in new installation list (just updates existing one)

Additional info:
Comment 1 David Shea 2014-01-14 14:24:57 EST
Does this problem still occur with the released versions of F19 or F20? If so, can you attach the log files from /tmp to this bug?
Comment 2 Branko Grubić 2014-02-22 12:07:08 EST
Sorry! I wasn't able to do it on time, I tested it now again with F20 DVD (final), it is still possible to get multiple entries in the list.
I formatted all partitions except one I used for /home on old system, and set mount point for it, then I checked the format checkbox it disappeared from bottom list and it was only in top list for new fedora install (which is OK). Then I tried to change it again, and unchecked the format checkbox, then it loses mount point (resets all fields I think? I didn't tried to change to different filesystem, encryption, ...), and I set it again to be new '/home' mount point without formatting (format checkbox unchecked) and I think it shows up twice then, and after few repeats (format (checked/unchecked), re-entering mount point without format ..., I'm able to create multiple entries for the same mountpoint in new install)


I'll add three different screenshots and log files.
Comment 3 Branko Grubić 2014-02-22 12:08:02 EST
Created attachment 866429 [details]
sshot0
Comment 4 Branko Grubić 2014-02-22 12:08:43 EST
Created attachment 866430 [details]
sshot1
Comment 5 Branko Grubić 2014-02-22 12:09:17 EST
Created attachment 866431 [details]
sshot2
Comment 6 Branko Grubić 2014-02-22 12:10:16 EST
Created attachment 866432 [details]
anaconda.log
Comment 7 Branko Grubić 2014-02-22 12:11:28 EST
Created attachment 866433 [details]
program.log
Comment 8 Branko Grubić 2014-02-22 12:12:40 EST
Created attachment 866434 [details]
storage.log
Comment 9 Branko Grubić 2014-02-22 12:15:44 EST
Sorry for the mess I did! I still have all /tmp files saved if some important file is missing here I can upload it.
Comment 10 David Shea 2014-12-09 09:37:59 EST
As far as I can tell this is working correctly in Fedora 21.

Note You need to log in before you can comment on or make changes to this bug.