Bug 978312 - krb5_get_init_creds_keytab() leaks memory
krb5_get_init_creds_keytab() leaks memory
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: krb5 (Show other bugs)
6.4
All Linux
urgent Severity high
: rc
: ---
Assigned To: Nalin Dahyabhai
Patrik Kis
: Patch, ZStream
Depends On: 911147
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-26 06:51 EDT by Jan Kurik
Modified: 2013-07-15 03:44 EDT (History)
12 users (show)

See Also:
Fixed In Version: krb5-1.10.3-10.el6_4.4
Doc Type: Bug Fix
Doc Text:
When the application lookup_etypes_for_keytab() function in krb5-libs attempted to use a keytab file to obtain initial credentials from a KDC, as a preliminary step, it enumerated the set of keys in the keytab to determine which types of keys it possessed. While doing so, it leaked memory. This update adds a krb5_kt_free_entry() call in this loop, and memory leaks no longer occur in the described scenario
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-15 03:44:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Kurik 2013-06-26 06:51:32 EDT
This bug has been copied from bug #911147 and has been proposed
to be backported to 6.4 z-stream (EUS).
Comment 7 errata-xmlrpc 2013-07-15 03:44:50 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1052.html

Note You need to log in before you can comment on or make changes to this bug.