Bug 978332 - DeployableContainer kills the managed server instead of regular shutdown in stop() on Windows
DeployableContainer kills the managed server instead of regular shutdown in s...
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Testsuite (Show other bugs)
6.1.0
Unspecified Unspecified
medium Severity low
: ER4
: EAP 6.1.1
Assigned To: Ivo Studensky
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-26 07:33 EDT by Ivo Studensky
Modified: 2013-10-15 13:20 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-16 16:24:33 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker WFLY-126 Critical Closed DeployableContainer kills the managed server instead of regular shutdown in stop() on Windows 2013-10-15 13:20:03 EDT

  None (edit)
Description Ivo Studensky 2013-06-26 07:33:15 EDT
Description of problem:
Backport of WFLY-126 to the EAP 6.1.x branch.

Upstream's description: 
This might be due to historical reasons for the TS to run faster, but this messes up clustering tests since shutdown is part of the test.

The problem is that Managed*DeployableContainer kills the managed server instead of regular shutdown in stop() on Windows. ARQ's stop is supposed to shutdown the server 'nicely', for abrupt termination there is jvmKill().

This was probably implemented like this incorrectly assuming that on windows, the process is sent SIGTERM like on *NIX-based OSes but there is no such thing on windows and the process is terminated immediately.

This shows up only in clustered tests, compared to other tests which dont rely on the shutdown sequence to be completed, but clustering testsuite relies on shutdown to disconnect the channel and leave the cluster without FD having to kick in.
Comment 1 Ivo Studensky 2013-06-26 08:01:36 EDT
Created a PR for this:

https://github.com/jbossas/jboss-eap/pull/202
Comment 2 Rostislav Svoboda 2013-06-27 08:00:12 EDT
TS improvement is welcome.
Comment 3 Richard Janík 2013-08-12 08:16:44 EDT
I do indeed see improvements in the clustering testsuite on Windows.
Comment 5 JBoss JIRA Server 2013-10-15 13:20:04 EDT
Radoslav Husar <rhusar@redhat.com> updated the status of jira WFLY-126 to Closed

Note You need to log in before you can comment on or make changes to this bug.