Bug 978333 - quota: alert-time modification shuts down the quotad
quota: alert-time modification shuts down the quotad
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: glusterd (Show other bugs)
2.1
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: vpshastry
Saurabh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-26 07:39 EDT by Saurabh
Modified: 2016-01-19 01:12 EST (History)
7 users (show)

See Also:
Fixed In Version: glusterfs-3.4.0.12rhs.beta2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-23 18:39:52 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
sosreport (11.39 MB, application/x-xz)
2013-06-26 07:49 EDT, Saurabh
no flags Details

  None (edit)
Description Saurabh 2013-06-26 07:39:37 EDT
Description of problem:
trying to change the alert-time to "20s" shuts down the quotad 
but the command returns success

[root@quota1 ~]# gluster volume info 
 
Volume Name: dist-rep
Type: Distributed-Replicate
Volume ID: 83fa9365-d5ed-49fd-a885-cf0280b7fa19
Status: Started
Number of Bricks: 6 x 2 = 12
Transport-type: tcp
Bricks:
Brick1: 10.70.37.98:/rhs/bricks/d1r1
Brick2: 10.70.37.174:/rhs/bricks/d1r2
Brick3: 10.70.37.136:/rhs/bricks/d2r1
Brick4: 10.70.37.168:/rhs/bricks/d2r2
Brick5: 10.70.37.98:/rhs/bricks/d3r1
Brick6: 10.70.37.174:/rhs/bricks/d3r2
Brick7: 10.70.37.136:/rhs/bricks/d4r1
Brick8: 10.70.37.168:/rhs/bricks/d4r2
Brick9: 10.70.37.98:/rhs/bricks/d5r1
Brick10: 10.70.37.174:/rhs/bricks/d5r2
Brick11: 10.70.37.136:/rhs/bricks/d6r1
Brick12: 10.70.37.168:/rhs/bricks/d6r2
Options Reconfigured:
features.alert-time: 20s
features.limit-usage: /:100GB,/dir:1GB
features.quota: on


Version-Release number of selected component (if applicable):
[root@quota1 ~]# rpm -qa | grep glusterfs
glusterfs-3.4rhs-1.el6rhs.x86_64
glusterfs-fuse-3.4rhs-1.el6rhs.x86_64
glusterfs-server-3.4rhs-1.el6rhs.x86_64
[root@quota1 ~]# 


How reproducible:
tried for the first time

Steps to Reproduce:
1. create a 6x2 volume, start it
2. gluster volume quota <vol-name> enable
3. gluster volume quota <vol-name> alert-time 20s
[root@quota1 ~]# gluster volume quota dist-rep alert-time 20s
features.alert-time on volume dist-rep set


Actual results:
the quotad is shut down

[root@quota1 ~]# ps -eaf | grep quotad
root      9438  2140  0 10:15 pts/0    00:00:00 grep quotad

glimpse of logs from,
[root@quota1 ~]# less /var/log/glusterfs/quotad.log

[2013-06-26 04:43:54.342399] E [options.c:130:xlator_option_validate_sizet] 0-quotad: invalid number format "20s" in option "dist-rep.alert-time"
[2013-06-26 04:43:54.342411] W [options.c:839:xl_opt_validate] 0-quotad: validate of dist-rep.alert-time returned -1
[2013-06-26 04:43:54.342422] E [graph.c:270:glusterfs_graph_validate_options] 0-quotad: validation failed: invalid number format "20s" in option "dist-rep.alert-time"
[2013-06-26 04:43:54.342431] E [graph.c:472:glusterfs_graph_activate] 0-graph: validate options failed
[2013-06-26 04:43:54.342637] W [glusterfsd.c:1011:cleanup_and_exit] (-->/usr/lib64/libgfrpc.so.0(rpc_clnt_handle_reply+0xa5) [0x35c080d3c5] (-->/usr/sbin/glusterfs(mgmt_getspec_cbk+0x2eb) [0x40bbdb] (-->/usr/sbin/glusterfs(glusterfs_process_volfp+0x106) [0x405016]))) 0-: received signum (0), shutting down

Expected results:
if the string is wrong then the command should fail, rather the quotad coming down.
Also, alert-time should be allowed to be set in "seconds", something I tried in the test mentioned above

Additional info:
Comment 3 Saurabh 2013-06-26 07:49:49 EDT
Created attachment 765527 [details]
sosreport
Comment 5 Scott Haines 2013-09-23 18:39:52 EDT
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. 

For information on the advisory, and where to find the updated files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1262.html
Comment 6 Scott Haines 2013-09-23 18:43:49 EDT
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. 

For information on the advisory, and where to find the updated files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1262.html

Note You need to log in before you can comment on or make changes to this bug.