Bug 978351 - GraphicsMagick needs to recognize aarch64 as 64bit arch
GraphicsMagick needs to recognize aarch64 as 64bit arch
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: GraphicsMagick (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Andreas Thienemann
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-26 08:38 EDT by Mark Salter
Modified: 2013-07-08 21:35 EDT (History)
3 users (show)

See Also:
Fixed In Version: GraphicsMagick-1.3.18-2.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-08 21:35:10 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mark Salter 2013-06-26 08:38:24 EDT
Description of problem:
Aarch64 needs to be added to list of 64bit arches in specfile.

diff --git a/GraphicsMagick.spec b/GraphicsMagick.spec
index fa19cc0..994b5a2 100644
--- a/GraphicsMagick.spec
+++ b/GraphicsMagick.spec
@@ -190,7 +190,7 @@ rm -rf %{buildroot}%{_datadir}/%{name}-%{version}/[a-b,d-z,A-Z]*
 rm -vf  %{buildroot}%{_libdir}/lib*.la
 
 # fix multilib issues
-%ifarch x86_64 s390x ia64 ppc64 sparc64
+%ifarch x86_64 s390x ia64 ppc64 sparc64 aarch64
 %define wordsize 64
 %else
 %define wordsize 32


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Rex Dieter 2013-06-26 08:59:14 EDT
Assuming aarch64 is multilib'd (ie an aarch64 system can install/run non-64bit aarch rpms)?
Comment 2 Mark Salter 2013-06-26 09:11:02 EDT
The h/w is capable of running 32-bit armv8 binaries but that is not yet fully supported. There are no current plans to support 32-bit, but that can change.
Comment 3 Rex Dieter 2013-06-26 09:16:02 EDT
ok, also

http://people.redhat.com/jcm/arm/masters_t_0120_hyperscale_redhat_powered_arm_server.pdf

says:
arch64 is entirely 64bit clean, with no 32bit aarch32 support.


closing->notabug

in short, I'd rather avoid the proliferation of hacks (multilib ones or otherwise) unless absolutely necessary.
Comment 4 Mark Salter 2013-06-26 09:21:37 EDT
Without the patch, builds of other packages using magick_types.h fail because magick_type.h looks for magick_types-64.h which won't exist unless aarch64 in in the specfile list of 64-bit arches.
Comment 5 Rex Dieter 2013-06-26 09:25:28 EDT
Oh crap, you're right, the hack in the .spec isn't conditional on multilib'ness.

I'll fix that.
Comment 6 Fedora Update System 2013-06-26 10:35:05 EDT
GraphicsMagick-1.3.18-2.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/GraphicsMagick-1.3.18-2.fc19
Comment 7 Fedora Update System 2013-06-26 13:08:05 EDT
Package GraphicsMagick-1.3.18-2.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing GraphicsMagick-1.3.18-2.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-11715/GraphicsMagick-1.3.18-2.fc19
then log in and leave karma (feedback).
Comment 8 Fedora Update System 2013-07-08 21:35:10 EDT
GraphicsMagick-1.3.18-2.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.