Bug 978360 - perl-DateTime 0.5300 has out-dated leap second database
perl-DateTime 0.5300 has out-dated leap second database
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: perl-DateTime (Show other bugs)
6.5
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Petr Pisar
Martin Kyral
: Patch
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-26 08:56 EDT by Petr Pisar
Modified: 2013-11-21 02:27 EST (History)
4 users (show)

See Also:
Fixed In Version: perl-DateTime-0.5300-2.el6
Doc Type: Bug Fix
Doc Text:
Cause: Computing time duration through 2012-06-30T23:59:60 second. Consequence: The duration won't be accurate. Fix: A leap second appended in the end of 2012-06-30 has been added to perl-DateTime leap second database. Result: Time arithmetic using Perl modules DateTime and DateTime::Duration recognize 2012-06-30 leap second correctly.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-21 02:27:12 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Reproducer (518 bytes, text/plain)
2013-06-26 09:08 EDT, Petr Pisar
no flags Details
Fix (1.58 KB, patch)
2013-06-26 09:37 EDT, Petr Pisar
no flags Details | Diff

  None (edit)
Description Petr Pisar 2013-06-26 08:56:22 EDT
perl-DateTime-0.5300 does not recognize leap second on 2012-07-01 because the leap second database compiled into DateTime is too old.

I propose updating the database and rebuild perl-DateTime

diff --git a/leaptab.txt b/leaptab.txt
index ef2ec12..f1c7f2e 100644
--- a/leaptab.txt
+++ b/leaptab.txt
@@ -22,3 +22,4 @@
 1999  Jan. 1  +1
 2006  Jan. 1  +1
 2009  Jan. 1  +1
+2012  Jul. 1  +1
Comment 1 Petr Pisar 2013-06-26 09:08:01 EDT
Created attachment 765575 [details]
Reproducer
Comment 2 Petr Pisar 2013-06-26 09:37:40 EDT
Created attachment 765591 [details]
Fix
Comment 11 errata-xmlrpc 2013-11-21 02:27:12 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1566.html

Note You need to log in before you can comment on or make changes to this bug.