This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 978370 - Wrong permissions on /usr/share/tomcat6
Wrong permissions on /usr/share/tomcat6
Status: CLOSED WORKSFORME
Product: JBoss Enterprise Web Server 2
Classification: JBoss
Component: tomcat6 (Show other bugs)
2.0.1
All Linux
unspecified Severity low
: ER03
: ---
Assigned To: Coty Sutherland
Jan Stourac
:
Depends On: 923825
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-26 09:14 EDT by Michal Haško
Modified: 2015-11-23 14:27 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Known Issue
Doc Text:
When using JBoss Enterprise Web Server 3.0 with Red Hat Enterprise Linux 5, the <filename class="directory">/usr/share/tomcat6</filename> directory does not have the appropriate permissions set. As a result, virtual hosts cannot be created as expected using the host-manager web application because the <literal>tomcat</literal> user cannot create a directory in <filename class="directory">/usr/share/tomcat6</filename>. This is a known issue is JBoss Enterprise Web Server 3.0 and no workaround is currently available for this issue.
Story Points: ---
Clone Of: 923825
Environment:
Last Closed: 2015-11-23 14:27:40 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Haško 2013-06-26 09:14:58 EDT
+++ This bug was initially created as a clone of Bug #923825 +++

Description of problem:
There are wrong permissions on /usr/share/tomcat6 in RHEL5. As a result, it is not possible to create virtual host through the host-manager webapp, because tomcat user cannot create a directory in /usr/share/tomcat6.

Version-Release number of selected component (if applicable):
tomcat6-6.0.37-8_patch_01.ep6.el5

How reproducible:
100%

Steps to Reproduce:
ls -ld /usr/share/tomcat6
  
Permissions are:
drwxrwxr-x root:root

But should be:
drwxrwxr-x root:tomcat
Comment 5 Michal Haško 2014-07-17 11:34:00 EDT
Fails on tomcat6-6.0.41-2_patch_01.ep6.el5

# ls -ld /usr/share/tomcat6
drwxrwxr-x 3 root root 4096 Jul 17 11:26 /usr/share/tomcat6
Comment 9 Coty Sutherland 2015-11-23 14:27:40 EST
Tested in the latest tomcat6 package on RHEL 5:

[root@rhel5 ~]# rpm -qa tomcat6
tomcat6-6.0.41-15_patch_04.ep6.el5
[root@rhel5 ~]# ls -ld /usr/share/tomcat6
drwxrwxr-x 3 root tomcat 4096 Nov 23 14:07 /usr/share/tomcat6

Additionally, JWS 3 isn't supported on RHEL 5 and doesn't provided tomcat6, so I'm not sure what the doctext is about...

I tested tomcat7 on RHEL 6 and verified it's good to go:

[root@rhel6 ~]# rpm -qa tomcat7
tomcat7-7.0.59-26_patch_00.ep7.el6.noarch
[root@rhel6 ~]# ls -ld /usr/share/tomcat7
drwxrwxr-x. 3 root tomcat 4096 Nov 23 14:23 /usr/share/tomcat

Note You need to log in before you can comment on or make changes to this bug.