Bug 978373 - Man pages for fence agents should make it clear when the parameter value is expected to be Python regular expression
Man pages for fence agents should make it clear when the parameter value is e...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: fence-agents (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Marek Grac
Cluster QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-26 09:22 EDT by Jan Pokorný
Modified: 2014-06-18 03:23 EDT (History)
2 users (show)

See Also:
Fixed In Version: fence-agents-4.0.2-1.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-13 07:24:13 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Pokorný 2013-06-26 09:22:24 EDT
Example:

# man fence_drac5 | grep -A1 cmd_prompt
       cmd_prompt
              Force command prompt (Default Value: ['\$'])

The dollar-sign is escaped only because it is treated as Python regular
expression under the hood.  This ought to be explained in the man page
so that no misunderstanding my arise when redefining the default value.
(something like "Force Python regex for command prompt").

For instance, if my fence device uses '.' as a prompt, I'd like to avoid
unneeded trial and error and use properly escaped '\.' as a cmd_prompt
value right away.

# rpm -q fence-agents-drac5
fence-agents-drac5-4.0.0-5.el7.x86_64


Two related notes:

1. to address using single-item-lists needlessly for default values
   (specifically in case of cmd_prompt as can also be observed above),
   I proposed a patch [1].  Thanks for considering it, Marku.

2. IIUIC, lists cannot be specified externally even when they
   are as default values (case of cmd_prompt at fence_apc, for instance)
   so the default values in man pages may still be confusing
   (patch [1] only fixed single-item-lists)


[1] https://www.redhat.com/archives/cluster-devel/2013-June/msg00181.html
Comment 1 Jan Pokorný 2013-06-26 09:25:22 EDT
Apparently, this applies to help texts (--help) as well.
Comment 3 Marek Grac 2013-07-01 08:52:50 EDT
Manual page was fixed in upstream:

https://git.fedorahosted.org/cgit/fence-agents.git/commit/?id=801d4575bff12924ae6ab56d4148e81a9e1cedd4

Problem with regex was solved by changing type of cmd-prompt - it is first value of newly created list. 

https://git.fedorahosted.org/cgit/fence-agents.git/commit/?id=c6d8c625c33451990473fef5ee735b18e28cdad1

Changing all command-prompts to just regex is surely an option but I don't like it very much because of fence agents that were not mentioned in patch. 

e.g. WTI:

all_opt["cmd_prompt"]["default"] = [ "RSM>", "MPC>", "IPS>", "TPS>", "NBB>", "NPS>", "VMR>" ]
Comment 6 Ludek Smid 2014-06-13 07:24:13 EDT
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.

Note You need to log in before you can comment on or make changes to this bug.