Bug 978379 - C++ example "client" raises a broker exception
C++ example "client" raises a broker exception
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: qpid-cpp (Show other bugs)
Development
Unspecified Windows
medium Severity medium
: 3.0
: ---
Assigned To: Gordon Sim
Petra Svobodová
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-26 09:48 EDT by Petra Svobodová
Modified: 2015-01-21 07:55 EST (History)
4 users (show)

See Also:
Fixed In Version: qpid-cpp-0.22-6.el6, qpid-cpp-mrg-0.22-6.el5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-01-21 07:55:31 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Apache JIRA QPID-4953 None None None Never

  None (edit)
Description Petra Svobodová 2013-06-26 09:48:42 EDT
Description of problem:

C++ example "client.exe" running simultaneously with "server" example (started after the "server) raises the exception on the connected broker, see transcriptions below:

Windows command line transcription:
...
C:\qpid_VS2008\bin\Release>client.exe 10.34.37.203
...
2013-06-26 09:17:25 [Client] warning Exception received from broker: not-found:
not-found: Queue not found: 92fd9aff-5fcc-43b6-82da-31988fdbd227# (/builddir/bui
ld/BUILD/qpid-0.22/cpp/src/qpid/broker/SessionAdapter.cpp:693) [caused by 4 \x08
:\x01]
Queue 92fd9aff-5fcc-43b6-82da-31988fdbd227# does not exist
...


Terminal transcription (qpidd.log):
...
013-06-26 13:29:56 [Broker] info Queue "service_queue": Flow limit created: flowStopCount=0, flowResumeCount=0, flowStopSize=83886080, flowResumeSize=73400320
2013-06-26 13:30:01 [Protocol] error Execution exception: not-found: Queue not found: 7f49a2ed-1a3c-49d5-b2ae-13c6ce3155d0# (/builddir/build/BUILD/qpid-0.22/cpp/src/qpid/broker/SessionAdapter.cpp:693)

Example "client" from the previous packages (qpid-cpp-win-3.2.0.4-1) works properly; the bug is only on this packages.


Version-Release number of selected component (if applicable):
qpid-cpp-win-3.22.5.1-1


How reproducible:
100%

Steps to Reproduce:
1. Unpack the qpid packages.
2. Create project files for examples and compile them.
3. Open a command line and start "server.exe" application.
4. In the second command line windows run "client.exe" application.

Actual results:
The "client.exe" example raises the exception on the broker.

Expected results:
The "client.exe" example should work without exceptions.
Comment 2 Gordon Sim 2013-06-26 10:31:14 EDT
This is not unique to windows. It is caused by a change I made to the example itself to better illustrate 1.0 behaviour. However at present the shorthand for a temporary queue - i.e. '#' - doesn't work for 0-10. Fix coming up shortly.
Comment 3 Gordon Sim 2013-06-26 12:40:24 EDT
Fixed upstream: https://svn.apache.org/r1496985
Comment 5 Petra Svobodová 2013-07-24 02:07:31 EDT
The "client" application works properly without exceptions.

Verified on all currently supported platforms:
- Rhel6.4-i686 and x86_64
- WindowsXP-x86
- Windows7-x86 and x64
- Windows Server2003-x86 and x64
- Windows Server2008-x86, x64 and R2

on packages qpid-cpp-0.22-7.el6 and qpid-cpp-win-3.22.7.1-1.

--> VERIFIED

Note You need to log in before you can comment on or make changes to this bug.