This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 978388 - Wrong Spring Framework version Spring Developer Guide
Wrong Spring Framework version Spring Developer Guide
Status: CLOSED CURRENTRELEASE
Product: JBoss Enterprise WFK Platform 2
Classification: JBoss
Component: doc-Spring-Developer-Guide (Show other bugs)
2.3.0
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Sneha
Tomas Repel
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-26 10:03 EDT by Tomas Repel
Modified: 2014-11-09 18:02 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-16 07:32:06 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tomas Repel 2013-06-26 10:03:06 EDT
Document URL: 

http://documentation-devel.engineering.redhat.com/docs/en-US/Red_Hat_JBoss_Web_Framework_Kit/2.3/html-single/Spring_Developer_Guide/index.html

Section Number and Name: 

1.1. Obtaining Spring

Describe the issue: 

Wrong version of Spring Framework `3.2.1.RELEASE`

Suggestions for improvement: 

Should be replaced by `3.2.3.RELEASE`
Comment 1 Sneha 2013-06-27 06:39:56 EDT
Updated the guide as per bug description.
Comment 2 Sneha 2013-06-28 02:27:23 EDT
Additionally, updated the following versions as confirmed by Tomas Repel:

location:
http://documentation-devel.engineering.redhat.com/docs/en-US/Red_Hat_JBoss_Web_Framework_Kit/2.3/html-single/Spring_Developer_Guide/index.html#appendix_petclinic_pom

Change:
1. spring-3.0-bom version to '2.3.0-redhat-1'
2. jboss-javaee-6.0 version to '3.0.2.Final-redhat-3'
Comment 3 Tomas Repel 2013-06-28 09:08:10 EDT
Sorry, I overlooked this, the wrong 3.2.1.RELEASE version of Spring is also in chapter 1.2. Spring JARs (it is in chapter 1.1. Obtaining Spring too), it should be 3.2.3.RELEASE.

3.1. Create the Quickstart Project
 - please change all occurrences of `member-registration` to `member_registration`. The reason for this is that dash (-) can't be used in Java package names, the underscore (_) can.

Chapter 4. Task Two: Run the Example
  - replace all occurrences of `greeter` by `member_registration` in this chapter, the project was named that way in previous chapter

I still can't see the changes mentioned in comment 2 when clicking on that link, please check it. Thanks
Comment 5 Tomas Repel 2013-07-01 05:54:36 EDT
Verified in WFK 2.3.0.CR1.

Note You need to log in before you can comment on or make changes to this bug.