Bug 978415 - vpx_config.h
vpx_config.h
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: libvpx (Show other bugs)
6.4
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Martin Stransky
BaseOS QE - Apps
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-26 10:44 EDT by Remi Collet
Modified: 2013-10-17 07:08 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-17 07:08:59 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Remi Collet 2013-06-26 10:44:53 EDT
Description of problem:
vpx_codec.h try to include missing vpx_config.h

Version-Release number of selected component (if applicable):
0.9.0-8.el6_0

How reproducible:
always

Steps to Reproduce:
1. try to build gd-2.1.0
2.
3.

Actual results:
In file included from /usr/include/vpx/vpx_decoder.h:32,
                 from webpimg.c:48:
/usr/include/vpx/vpx_codec.h:45:26: error: vpx_config.h: No such file or directory


Expected results:
no error.

Additional info:
From vpx_codec.h:
#ifdef HAVE_CONFIG_H
#  include "vpx_config.h"
#endif

Problem: lot of program build with -DHAVE_CONFIG_H

Newer versions doesn't have this include anymore.

Workaround exists:
touch vpx_config.h
Comment 2 RHEL Product and Program Management 2013-10-13 19:26:31 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.
Comment 3 Martin Stransky 2013-10-17 07:08:59 EDT
I'm afraid we're not going to update libvpx library on RHEL6, it's too low-profile component.

Note You need to log in before you can comment on or make changes to this bug.