Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 978419 - RFE: Change in rhel6 guest kickstarts
Summary: RFE: Change in rhel6 guest kickstarts
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Beaker
Classification: Retired
Component: scheduler
Version: develop
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: 0.14
Assignee: Raymond Mancy
QA Contact: tools-bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-06-26 14:48 UTC by Gurhan Ozen
Modified: 2018-02-06 00:41 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-08-09 03:24:46 UTC


Attachments (Terms of Use)

Description Gurhan Ozen 2013-06-26 14:48:58 UTC
Description of problem:
I would like some extra serial console information to be added to the rhel6 guests' kickstart files so that connecting to the serial console while getting the serial console logs can be possible. A plain diff in below:


# diff ./349800.cfg /var/www/html/ks.cfg 
7c7
< bootloader --location=mbr
---
> bootloader --location=mbr --append="console=ttyS0,115200 console=ttyS1,115200"
331,332d330
< %end
< 										
333a332,354
> cat << EOF >/etc/init/ttyS0.conf
> # start ttyS0
> start on runlevel [2345]
> stop on runlevel [S016]
> instance ttyS0
> respawn
> pre-start exec /sbin/securetty ttyS0
> exec /sbin/agetty /dev/ttyS0 115200 vt100-nav
> EOF
> initctl start ttyS0
> 
> cat << EOF >/etc/init/ttyS1.conf
> # start ttyS1
> start on runlevel [2345]
> stop on runlevel [S016]
> instance ttyS1
> respawn
> pre-start exec /sbin/securetty ttyS1
> exec /sbin/agetty /dev/ttyS1 115200 vt100-nav
> EOF
> initctl start ttyS1
> 
> %end

It just appends the console args to the bootloader command and has setting up serial consoles in the %post section.

Version-Release number of selected component (if applicable):
0.13

How reproducible:
It's an RFE

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Raymond Mancy 2013-07-02 08:47:21 UTC
http://gerrit.beaker-project.org/#/c/2068/

Comment 7 Raymond Mancy 2013-07-23 13:15:51 UTC
http://gerrit.beaker-project.org/#/c/2113/

This patch is needed to remove the initctl error.

However, this patch doesn't quite work, because the guest's xml definition
does not include the additional serial entry. and so 'virsh console' behaviour does not change.

Comment 8 Gurhan Ozen 2013-07-23 14:42:06 UTC
(In reply to Raymond Mancy from comment #7)
> http://gerrit.beaker-project.org/#/c/2113/
> 
> This patch is needed to remove the initctl error.
> 
> However, this patch doesn't quite work, because the guest's xml definition
> does not include the additional serial entry. and so 'virsh console'
> behaviour does not change.

Yes, we need --serial pty and console=ttyS1,115200 args to be added to virt-install command line.

I have intentionally didn't mention those in this bug since that would be a test level change, i thought we'd just update the test after this change to kickstarts are in. And this change to the kickstarts wouldn't break anything in the meantime. 

If you want to test this feature, maybe sure that virt-install has "--serial pty" args and --extra-args argument also has "console=ttyS1,115200".

For example:

"virt-install --name rhel6u4_x86_64_cli_b --mac 52:57:00:00:00:06 --location nfs://bigpapi.bos.redhat.com:/vol/engarchive2/redhat/released/RHEL-6/6.4/Server/x86_64/os/ -s 10 -r 2048 --hvm --debug --prompt --accelerate --os-variant=virtio26 --network bridge:br0 --serial file,path=/mnt/tests/distribution/virt/install/guests/rhel6u4_x86_64_cli_b/logs/rhel6u4_x86_64_cli_b_console.log --serial pty --file /var/lib/libvirt/images/rhel6u4_x86_64_cli_b.img --extra-args "ks=http://beaker-devel.app.eng.bos.redhat.com/kickstart/1108 serial console=tty0 console=ttyS0,115200 console=ttyS1,115200" --noreboot --vnc"

Cheers,
Gurhan

Comment 10 Dan Callaghan 2013-08-09 03:24:46 UTC
Beaker 0.14.1 has been released.


Note You need to log in before you can comment on or make changes to this bug.