Bug 978422 - it is possible to set 'End Date' before 'Start Date' during report filter creation
it is possible to set 'End Date' before 'Start Date' during report filter cre...
Status: CLOSED ERRATA
Product: Subscription Asset Manager
Classification: Red Hat
Component: Splice (Show other bugs)
1.3
Unspecified Unspecified
unspecified Severity unspecified
: rc
: 1.3
Assigned To: Pavlina Bartikova
mkovacik
:
Depends On:
Blocks: sam13-tracker
  Show dependency treegraph
 
Reported: 2013-06-26 10:53 EDT by Vitaly Kuznetsov
Modified: 2013-10-01 07:00 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-01 07:00:42 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
mkovacik: automate_bug+


Attachments (Terms of Use)
sam screenshot (70.01 KB, image/png)
2013-08-13 13:35 EDT, Pavlina Bartikova
no flags Details

  None (edit)
Description Vitaly Kuznetsov 2013-06-26 10:53:47 EDT
Description of problem:
It is possible to set 'End Date' before 'Start Date' during report filter creation. Surprisingly the resulting report can be non-empty.

I would suggest adding validation for filter creation (End Date >= Start Date)

Version-Release number of selected component (if applicable):
ruby193-rubygem-splice_reports-0.0.5-27.el6sam

How reproducible:
always

Steps to Reproduce:
1. During filter creation select End Date before Start Date

Actual results:
It's possible to create such filter

Expected results:
Error message displayed

Additional info:
Comment 1 wes hayutin 2013-07-17 17:42:44 EDT
commit 7df4f7623da9f6161d6425e4ce0cb699064d7df4
Comment 2 Bryan Kearney 2013-08-02 14:52:31 EDT
SNAP0 contains these bug fixes. Moving to ON_QA.
Comment 3 Pavlina Bartikova 2013-08-13 13:35:48 EDT
Created attachment 786225 [details]
sam screenshot

Confirmed.

Moving bug to VERIFIED.
Comment 5 errata-xmlrpc 2013-10-01 07:00:42 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1390.html

Note You need to log in before you can comment on or make changes to this bug.