Bug 978428 - [abrt] WARNING: at drivers/gpu/drm/i915/intel_display.c:3854 intel_modeset_check_state+0x5f9/0x600 [i915]()
[abrt] WARNING: at drivers/gpu/drm/i915/intel_display.c:3854 intel_modeset_ch...
Status: CLOSED DUPLICATE of bug 958295
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-intel (Show other bugs)
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2013-06-26 11:02 EDT by Northcott
Modified: 2014-05-21 13:34 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2014-05-21 13:34:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
File: dmesg (116.74 KB, text/plain)
2013-06-26 11:02 EDT, Northcott
no flags Details

  None (edit)
Description Northcott 2013-06-26 11:02:16 EDT
Description of problem:
It seems to happen at random after logging in, or when unlocking after opening the lid (I'm on a laptop).  ABRT reports this occurring 6 or 8 times.  IIRC this is the same error I've gotten under Fedora 17 (I skipped 18 and just installed and updated 19 beta).

Additional info:
reporter:       libreport-2.1.5
WARNING: at drivers/gpu/drm/i915/intel_display.c:3854 intel_modeset_check_state+0x5f9/0x600 [i915]()
Hardware name: Inspiron 1525                   
wrong connector dpms state
Modules linked in: ipt_MASQUERADE nf_conntrack_netbios_ns nf_conntrack_broadcast ip6table_nat nf_nat_ipv6 ip6table_mangle ip6t_REJECT nf_conntrack_ipv6 bnep nf_defrag_ipv6 bluetooth iptable_nat nf_nat_ipv4 nf_nat iptable_mangle nf_conntrack_ipv4 nf_defrag_ipv4 xt_conntrack nf_conntrack ebtable_filter ebtables ip6table_filter ip6_tables uvcvideo videobuf2_vmalloc videobuf2_memops videobuf2_core videodev media acpi_cpufreq mperf coretemp kvm_intel kvm b43 bcma arc4 snd_hda_codec_idt snd_hda_codec_hdmi iTCO_wdt iTCO_vendor_support dell_wmi iwl4965 iwlegacy snd_hda_intel snd_hda_codec sparse_keymap mac80211 dell_laptop sdhci_pci sdhci snd_hwdep dcdbas r592 memstick serio_raw snd_seq microcode i2c_i801 joydev ssb cfg80211 rfkill snd_seq_device mmc_core snd_pcm lpc_ich mfd_core snd_page_alloc snd_timer snd soundcore wmi sky2 dm_crypt firewire_ohci usb_storage firewire_core i915 crc_itu_t i2c_algo_bit drm_kms_helper drm i2c_core video uinput
Pid: 747, comm: Xorg Not tainted 3.9.2-301.fc19.x86_64 #1
Call Trace:
 [<ffffffffa00b9600>] ? intel_modeset_check_state+0x510/0x600 [i915]
 [<ffffffff8105cd86>] warn_slowpath_common+0x66/0x80
 [<ffffffff8105cdec>] warn_slowpath_fmt+0x4c/0x50
 [<ffffffffa00b96e9>] intel_modeset_check_state+0x5f9/0x600 [i915]
 [<ffffffffa00b9785>] intel_set_mode+0x25/0x30 [i915]
 [<ffffffffa00ba873>] intel_get_load_detect_pipe+0x253/0x410 [i915]
 [<ffffffffa00d76e0>] intel_tv_detect+0x100/0x490 [i915]
 [<ffffffffa00145a5>] ? i2c_unlock_adapter+0x25/0x40 [i2c_core]
 [<ffffffffa007e752>] drm_helper_probe_single_connector_modes+0x1d2/0x340 [drm_kms_helper]
 [<ffffffffa0036faf>] drm_mode_getconnector+0x3ff/0x480 [drm]
 [<ffffffffa00282c9>] drm_ioctl+0x4e9/0x5b0 [drm]
 [<ffffffffa0036bb0>] ? drm_mode_getcrtc+0xd0/0xd0 [drm]
 [<ffffffff811aaef5>] do_vfs_ioctl+0x305/0x520
 [<ffffffff812943ae>] ? file_has_perm+0x8e/0xa0
 [<ffffffff811ab191>] sys_ioctl+0x81/0xa0
 [<ffffffff8164dd19>] system_call_fastpath+0x16/0x1b
Comment 1 Northcott 2013-06-26 11:02:22 EDT
Created attachment 765638 [details]
File: dmesg
Comment 2 Adam Jackson 2014-05-21 13:34:23 EDT

*** This bug has been marked as a duplicate of bug 958295 ***

Note You need to log in before you can comment on or make changes to this bug.