Bug 978432 - tests are packaged in splice
tests are packaged in splice
Status: CLOSED ERRATA
Product: Subscription Asset Manager
Classification: Red Hat
Component: Splice (Show other bugs)
1.3
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Splice Developers
mkovacik
:
Depends On:
Blocks: sam13-tracker
  Show dependency treegraph
 
Reported: 2013-06-26 11:18 EDT by Vitaly Kuznetsov
Modified: 2013-10-01 07:00 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-01 07:00:48 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vitaly Kuznetsov 2013-06-26 11:18:06 EDT
Description of problem:
There are tests packaged under /usr/lib/python2.6/site-packages/splice/entitlement/ directory in splice package as well as /etc/splice/logging/unittests.cfg is packaged in splice-common-config and splice-common packages.
I would suggest we separate tests in splice-tests package to avoid installing them in production.

Version-Release number of selected component (if applicable):
splice-common-config-0.130-1.el6sam.noarch
splice-common-0.130-1.el6sam.noarch
splice-0.130-1.el6sam.noarch
Comment 1 John Matthews 2013-07-16 12:12:13 EDT
Opted to remove the tests from the RPM, opposed to creating a separate test package.

https://github.com/splice/splice-server/commit/b8bb1acf1b6e9c37e0b9cb76b68925e3d2a68d5c

https://github.com/splice/splice-server/commit/77032a81ad03adcc10b32f8b6911798fd8306cbc
Comment 2 Bryan Kearney 2013-08-02 14:51:56 EDT
SNAP0 contains these bug fixes. Moving to ON_QA.
Comment 3 Pavlina Bartikova 2013-08-14 11:47:25 EDT
The tests were removed from /usr/lib/python2.6/site-packages/splice/entitlement/, but /etc/splice/logging/unittests.cfg is still there.

Version:
splice-common-0.141-1.el6sam.noarch
splice-common-config-0.141-1.el6sam.noarch

Moving bug to ASSIGNED.
Comment 4 John Matthews 2013-08-14 12:11:22 EDT
Fixed below, will be in 0.142

https://github.com/splice/splice-server/commit/ed429e66e8ee4267947383b9c3beea8b9d474f29

$ rpm -ql -p /tmp/tito/noarch/splice-0.142-1.fc18.noarch.rpm  | grep test
Comment 5 Pavlina Bartikova 2013-08-21 09:17:07 EDT
Confirmed.

Moving bug to VERIFIED.
Comment 7 errata-xmlrpc 2013-10-01 07:00:48 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1390.html

Note You need to log in before you can comment on or make changes to this bug.