Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 978433 - iptraf-ng core dumps when strarting to do the actual trace
Summary: iptraf-ng core dumps when strarting to do the actual trace
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: iptraf-ng
Version: el6
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Nikola Pajkovsky
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-06-26 15:23 UTC by Andrew Meredith
Modified: 2014-02-02 22:18 UTC (History)
2 users (show)

Fixed In Version: iptraf-ng-1.1.4-1.fc18
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-08-02 03:34:36 UTC
Type: Bug


Attachments (Terms of Use)

Description Andrew Meredith 2013-06-26 15:23:18 UTC
Description of problem:

iptraf-ng repeatably core dumps when you select "IP Traffic Monitor" and a device.

Version-Release number of selected component (if applicable):

iptraf-ng-1.1.1-2.el6.x86_64

How reproducible:

Every time

Steps to Reproduce:
1. iptraf-ng
2. "IP Traffic Monitor"
3. Select a device

Actual results:

Program received signal SIGABRT, Aborted.
0x000000344cc328a5 in raise () from /lib64/libc.so.6
Missing separate debuginfos, use: debuginfo-install glibc-2.12-1.107.el6.x86_64 libgcc-4.4.7-3.el6.x86_64 ncurses-libs-5.7-3.20090208.el6.x86_64
(gdb) bt
#0  0x000000344cc328a5 in raise () from /lib64/libc.so.6
#1  0x000000344cc34085 in abort () from /lib64/libc.so.6
#2  0x000000344cc707b7 in __libc_message () from /lib64/libc.so.6
#3  0x000000344cc760e6 in malloc_printerr () from /lib64/libc.so.6
#4  0x000000344cc78c13 in _int_free () from /lib64/libc.so.6
#5  0x000000000041a02c in destroyiflist (list=<value optimized out>) at ifstats.c:200
#6  0x000000000041a3e8 in selectiface (ifname=0x7fffffffdf50 "lo", withall=1, aborted=0x7fffffffddd4)
    at ifstats.c:1389
#7  0x0000000000410658 in program_interface (options=0x7fffffffdfb0, opt=<value optimized out>, 
    optarg=<value optimized out>, facilitytime=<value optimized out>) at iptraf.c:203
#8  0x0000000000410c9e in main (argc=<value optimized out>, argv=<value optimized out>) at iptraf.c:567


Expected results:

Traffic info

Additional info:

This seems to be the same issue as the one recently raised and cleared for Fedora.

Comment 2 Nikola Pajkovsky 2013-07-11 14:37:29 UTC
I think it's fixed. Care to test build?

Comment 3 Andrew Meredith 2013-07-11 15:41:26 UTC
Sure .. where's the new source. Unless there is a prebuilt package?

Comment 4 Nikola Pajkovsky 2013-07-11 17:41:38 UTC
give it try http://koji.fedoraproject.org/koji/taskinfo?taskID=5596120

Comment 5 Nikola Pajkovsky 2013-07-16 08:48:24 UTC
Andrew, did you try it? Does it work?

Comment 6 Andrew Meredith 2013-07-16 09:06:42 UTC
Sorry, didn't catch the "Pajkovsky 2013-07-11 13:41:38 EDT" update for some reason. Thanks for the poke.

Yes. Works a treat. I tried it on two dissimilar machines, both of which I tested just before installing to confirm the fault. Both of which now work reliably across all of the active screens.

Nice one. Thanks for fixing this. To me it is a vital tool and its absence was quite debilitating.

Comment 7 Nikola Pajkovsky 2013-07-16 09:40:14 UTC
Cool, stick on this build, and I will push iptraf-ng-1.1.4 out very soon. Thanks.

Comment 8 Fedora Update System 2013-07-23 15:34:32 UTC
iptraf-ng-1.1.4-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/iptraf-ng-1.1.4-1.fc18

Comment 9 Fedora Update System 2013-07-23 15:35:42 UTC
iptraf-ng-1.1.4-1.el5 has been submitted as an update for Fedora EPEL 5.
https://admin.fedoraproject.org/updates/iptraf-ng-1.1.4-1.el5

Comment 10 Fedora Update System 2013-07-23 15:37:07 UTC
iptraf-ng-1.1.4-1.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/iptraf-ng-1.1.4-1.el6

Comment 11 Fedora Update System 2013-07-23 15:38:05 UTC
iptraf-ng-1.1.4-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/iptraf-ng-1.1.4-1.fc19

Comment 12 Fedora Update System 2013-07-23 19:40:51 UTC
Package iptraf-ng-1.1.4-1.el5:
* should fix your issue,
* was pushed to the Fedora EPEL 5 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=epel-testing iptraf-ng-1.1.4-1.el5'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-EPEL-2013-10955/iptraf-ng-1.1.4-1.el5
then log in and leave karma (feedback).

Comment 13 Fedora Update System 2013-08-02 03:34:36 UTC
iptraf-ng-1.1.4-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 14 Fedora Update System 2013-08-02 03:36:13 UTC
iptraf-ng-1.1.4-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 15 Fedora Update System 2013-09-02 12:04:31 UTC
iptraf-ng-1.1.4-2.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/iptraf-ng-1.1.4-2.fc18

Comment 16 Fedora Update System 2013-09-02 12:05:08 UTC
iptraf-ng-1.1.4-2.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/iptraf-ng-1.1.4-2.fc19

Comment 17 Fedora Update System 2013-09-02 12:05:41 UTC
iptraf-ng-1.1.4-2.el5 has been submitted as an update for Fedora EPEL 5.
https://admin.fedoraproject.org/updates/iptraf-ng-1.1.4-2.el5

Comment 18 Fedora Update System 2013-09-02 12:06:14 UTC
iptraf-ng-1.1.4-2.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/iptraf-ng-1.1.4-2.el6

Comment 19 Fedora Update System 2013-09-11 01:51:20 UTC
iptraf-ng-1.1.4-2.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 20 Fedora Update System 2013-09-11 01:53:34 UTC
iptraf-ng-1.1.4-2.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 21 Fedora Update System 2013-09-17 17:26:51 UTC
iptraf-ng-1.1.4-2.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 22 Fedora Update System 2013-09-17 17:27:20 UTC
iptraf-ng-1.1.4-2.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.