Bug 978492 - ActiveMQ fix for memory leak
ActiveMQ fix for memory leak
Status: CLOSED ERRATA
Product: OpenShift Container Platform
Classification: Red Hat
Component: Pod (Show other bugs)
1.2.0
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Jason DeTiberus
libra bugs
:
Depends On:
Blocks: 906885
  Show dependency treegraph
 
Reported: 2013-06-26 13:37 EDT by Luke Meyer
Modified: 2017-03-08 12 EST (History)
4 users (show)

See Also:
Fixed In Version: activemq-5.8.0-1.redhat.60024.el6op
Doc Type: Bug Fix
Doc Text:
Due to a bug in ActiveMQ's memory management, memory leaks could require ActiveMQ to be restarted, most noticeably under heavy load. With this fix, ActiveMQ in OpenShift Enterprise has been upgraded to the latest stable release from JBoss AM-Q. As a result, ActiveMQ no longer suffers from memory leaks.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-05 13:17:56 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Luke Meyer 2013-06-26 13:37:56 EDT
Description of problem:
Although no Enterprise incidence of this has yet surfaced, there have been occurrences of a memory leak in Online ActiveMQ servers that appear to be related to https://issues.apache.org/jira/browse/AMQ-4319 and backported to 5.8.0.

Version-Release number of selected component (if applicable):
activemq-5.6.0-5.el6op

How reproducible:
So far, not at all.

Actual results:
ActiveMQ heap usage grows until OOME and restart, generally not failing over gracefully.

Expected results:
Heap usage does not increase out of proportion to existing storage/usage.
Comment 3 Jason DeTiberus 2013-07-12 13:16:09 EDT
Built activemq-5.8.0-1.redhat.60024.el6op, will be included in the next puddle built.
Comment 5 Gaoyun Pei 2013-07-15 22:28:28 EDT
The new puddle 2013-07-12 is using activemq-5.8.0-1.redhat.60024.el6op.x86_64.

In the beginning of testing, check the mem usage of activemq:
PID  USER      PR  NI  VIRT  RES  SHR S %CPU %MEM    TIME+  COMMAND                                                                                          
                                                                                             
4940 activemq  20   0 2501m 248m  12m S  3.0  6.5   1:24.97 java


After a round of acceptance testing, check the usage again:
PID USER      PR  NI  VIRT  RES  SHR S %CPU %MEM    TIME+  COMMAND            
             
4940 activemq  20   0 3282m 257m  12m S  0.7  6.7   8:22.36 java               

ActiveMQ took proper usage of MEM during it's running, so move it to VERIFIED.
Comment 8 errata-xmlrpc 2013-08-05 13:17:56 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1138.html

Note You need to log in before you can comment on or make changes to this bug.