Bug 9785 - APMD kills kernel on shutdown.
APMD kills kernel on shutdown.
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
6.2
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-02-25 13:09 EST by David D.W. Downey
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-02-25 13:26:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David D.W. Downey 2000-02-25 13:09:21 EST
** KERNEL CRASH ON SHUTDOWN! **   Ran simple 'halt' and kernel died
horrbily! Got following error dump (some cut out like register info)

        Code <1> Unable to handle kernel paging request at virtual address
        00008875
        current->tss.cr3 = 089ad00, %cr3= 089ad000
        *pde = 00000000
        Ooops: 0000
        CPU: 0
        <snip register contents>
        Process halt (pid 1119, process nr=46, STACKpage=c89dd000)
        <snip remaining register dumps and Code:
dump>


The halt (or even shutdown -h now) command, the death takes place exactly
as it says it's stopping al md devices. It pauses for a second and then
blows up. APM is off in the BIOS, APM was turned off via chkconfig and
service stopped prior to shut down.
Comment 1 Bernhard Rosenkraenzer 2000-02-25 13:26:59 EST
This is a bug in your BIOS, not in apmd (which isn't even running at that point)
or the kernel.
What happens is the following:
- You tell the computer to shutdown.
- SysVInit kills all running processes (including APMD)
- the kernel shuts down, and tells the APM BIOS to turn off power
- your APM BIOS is buggy, can't execute the request and doesn't return an
  error code either, so it crashes.
  This is normally related to the APM BIOS not handling 32-bit mode calls
  (that's why the problem doesn't occur with Windows).
Turning APM off in the CMOS setup has nothing to do with this: it only turns off
stuff like disk spindown.

It is nothing to really worry about though: Since everything has been stopped,
the crash is harmless. Consider it a fancy version of saying "It is safe to turn
off your computer now". ;)

Note You need to log in before you can comment on or make changes to this bug.