Bug 978503 - [RFE] GlusterFS native support with QEMU
[RFE] GlusterFS native support with QEMU
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-nova (Show other bugs)
4.0
Unspecified Unspecified
medium Severity unspecified
: Upstream M3
: 4.0
Assigned To: Eric Harney
Dafna Ron
https://blueprints.launchpad.net/nova...
storage
: FutureFeature
Depends On: 956919 1020979 1045047
Blocks: RHOS40RFE 997553
  Show dependency treegraph
 
Reported: 2013-06-26 13:46 EDT by Russell Bryant
Modified: 2016-04-27 00:08 EDT (History)
13 users (show)

See Also:
Fixed In Version: openstack-nova-2013.2-0.23.rc1.el6
Doc Type: Known Issue
Doc Text:
Compute is able to use libgfapi to connect to Block Storage GlusterFS volumes. However, a known issue exists where libvirt/Compute does not support Block Storage snapshots with this feature. This means that: * You can: --Use the Block Storage GlusterFS plugin to set Red Hat Storage as the storage provider for OpenStack Block Storage. --Create Block Storage volumes in the above setup and attach those volumes to a Compute instance using FUSE. --Create Block Storage snapshots and clones of these Block Storage volumes. * You CANNOT: --Attach those Block Storage volumes to a Compute instance via QEMU Gluster Blockdriver libgfapi. --Create snapshots of a Block Storage volume that is attached to a Compute instance via libgfapi when using the GlusterFS plugin.
Story Points: ---
Clone Of:
: 997553 (view as bug list)
Environment:
Last Closed: 2013-12-19 19:10:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenStack gerrit 39498 None None None Never

  None (edit)
Comment 1 Stephen Gordon 2013-07-26 16:43:22 EDT
I'm setting docs_scoped- on this based on the available state but if things change, particularly if this is as suggested switched based on a configuration flag, we'll need to re-evaluate.
Comment 2 Eric Harney 2013-08-15 09:55:43 EDT
(In reply to Stephen Gordon from comment #1)
> I'm setting docs_scoped- on this based on the available state but if things
> change, particularly if this is as suggested switched based on a
> configuration flag, we'll need to re-evaluate.

The code upstream for this feature has it disabled by default and a config option to enable it.  ( https://review.openstack.org/#/c/39498/12/etc/nova/nova.conf.sample )
Comment 5 Dafna Ron 2013-11-21 06:51:09 EST
Eric, 
To my understanding we need to configure glance to work with a gluster mount and run instances from the image? 

Please specify if we need to specify any configuration in glance and libvirt as well as qemu to allow such configuration.
Comment 6 Eric Harney 2013-12-02 10:13:44 EST
(In reply to Dafna Ron from comment #5)
> Eric, 
> To my understanding we need to configure glance to work with a gluster mount
> and run instances from the image? 
> 
> Please specify if we need to specify any configuration in glance and libvirt
> as well as qemu to allow such configuration.

This is a Cinder/Nova feature and doesn't affect Glance.  If qemu_allowed_storage_drivers is set to "gluster" in Nova, Nova will use libgfapi when attaching Gluster Cinder volumes.
Comment 8 Dafna Ron 2013-12-11 11:30:48 EST
see bug 1020979 for configuration
Comment 9 Dafna Ron 2013-12-12 05:56:16 EST
This RFE is blocked by 1020979 - we cannot attach the volume when using libgfapi
Comment 10 Summer Long 2013-12-15 17:14:57 EST
New doc text with notes from Tushar Katarki.
Comment 12 Summer Long 2013-12-16 18:27:45 EST
See question in email thread.
Comment 16 errata-xmlrpc 2013-12-19 19:10:45 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1859.html

Note You need to log in before you can comment on or make changes to this bug.