Bug 97852 - init problem: cannot handle file 'libc.so.6' with TLS data
init problem: cannot handle file 'libc.so.6' with TLS data
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: tripwire (Show other bugs)
8.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Jeff Johnson
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-06-23 05:24 EDT by Toni Willberg
Modified: 2007-04-18 12:54 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-25 12:38:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Toni Willberg 2003-06-23 05:24:49 EDT
glibc-2.3.2-53
openssl-0.9.7a-9
redhat-release-8.0-8
tripwire-2.3.1-14
(all rawhide but tripwire)


I installed Tripwire, ran /etc/tripwire/twinstall.sh which generated simple
config and created keys.


At initial run I got following error: (same happens on every re-try)

$tripwire  --init -v
Tripwire(R) 2.3.1.2 for Linux
... 
Opening configuration file: /etc/tripwire/tw.cfg
This file is encrypted.
 
Opening key file: /etc/tripwire/site.key
Opening key file: /etc/tripwire/host.example.com-local.key
Please enter your local passphrase:
Opening key file: /etc/tripwire/site.key
Opening policy file: /etc/tripwire/tw.pol
This file is encrypted.
Parsing policy file: /etc/tripwire/tw.pol
Generating the database...
*** Processing Unix File System ***
Processing:  /
--- Generating information for: /
cannot handle file 'libc.so.6' with TLS data
Comment 1 Jeff Johnson 2003-06-25 12:38:45 EDT
You're mixing and matching packages that have been
compiled with and without TLS data.

The only wait out is to recompile packages without
TLS on a TLS aware system, there's no other fix afaik.

So, you need to recompile tripwire on a TLS asware build system.

WONTFIX because tripwire is no longer supported (for some definition of
"support") on RHL.

Note You need to log in before you can comment on or make changes to this bug.