Bug 978537 - [RFE] Need ability in API to edit default quotas
[RFE] Need ability in API to edit default quotas
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-nova (Show other bugs)
4.0
Unspecified Unspecified
low Severity unspecified
: Upstream M1
: 4.0
Assigned To: Xavier Queralt
Omri Hochman
https://blueprints.launchpad.net/nova...
: FutureFeature, OtherQA
: 976464 (view as bug list)
Depends On: 989591
Blocks: RHOS40RFE
  Show dependency treegraph
 
Reported: 2013-06-26 14:29 EDT by Russell Bryant
Modified: 2014-06-02 22:35 EDT (History)
9 users (show)

See Also:
Fixed In Version: openstack-nova-2013.2-0.8.b2.el6ost
Doc Type: Enhancement
Doc Text:
Default quotas can now be defined from the command line and dashboard. The new defaults are stored in the database under the class 'default', and will override any defaults specified in nova.conf. A nova restart is not required when the defaults are defined with the nova client: nova client nova quota-class-update default <key> <value>
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-19 19:11:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Ami Jeain 2013-07-15 09:13:34 EDT
Horizon has a default quota UI which is currently Read-Only. This UI should allow admins to edit the quota defaults
Comment 6 Xavier Queralt 2013-10-08 07:29:39 EDT
*** Bug 976464 has been marked as a duplicate of this bug. ***
Comment 9 Omri Hochman 2013-12-16 09:48:41 EST
Verified (with puddle 2013-10-03.3) : 

See TCMS Results : 
------------------
https://tcms.engineering.redhat.com/run/89114/?from_plan=9876
Comment 11 errata-xmlrpc 2013-12-19 19:11:18 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1859.html

Note You need to log in before you can comment on or make changes to this bug.