Bug 978584 - mount option acl has no effect when samba mount is mounted via gluster volume start
mount option acl has no effect when samba mount is mounted via gluster volume...
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: samba (Show other bugs)
2.0
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Raghavendra Talur
surabhi
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-26 16:53 EDT by Balaji
Modified: 2013-09-23 18:32 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-23 18:32:16 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Balaji 2013-06-26 16:53:43 EDT
Description of problem:
Enabling ACL for the samba mounted filesystem automated by gluster volume start.

When a gluster volume is started, the first time it appends an entry to the /etc/fstab file with the samba mount point. This step is performed by the hook script - /var/lib/glusterd/hooks/1/start/post/S30samba-start.sh

However this entry in the fstab file does not enable ACL option. To automate this, the hook script was edited to add 'acl' in the options. When the gluster was started the first time, it added the acl option in the fstab file as described below:
ad-rhs-srv1.cloud.lab.eng.bos.redhat.com:/dfilevol01 /mnt/samba/dfilevol01 glusterfs defaults,acl,transport=tcp 0 0

However the acl option does not take effect in the mounted filesystem /mnt/samba/dfilevol01. When the filesystem is manually unmounted and mounted again, acl gets enabled.



Version-Release number of selected component (if applicable):
RHS 2.0
2.6.32-220.34.1.el6  (Anshi Update 4)



How reproducible:


Steps to Reproduce:
1. Create a new gluster volume
2. Edit the hook - /var/lib/glusterd/hooks/1/start/post/S30samba-start.sh and add 'acl' next to defaults in the fstab section.
[mntent="`hostname`:/$volname $mntpt glusterfs defaults,acl,transport=tcp 0 0"]
3. Start the gluster volume, verify the samba mount using df -h command and check mount options by running "mount" command:

Actual results:
# mount | grep new
ad-rhs-srv1.cloud.lab.eng.bos.redhat.com:new on /mnt/samba/new type fuse.glusterfs (rw,default_permissions,allow_other,max_read=131072)

Expected results:
# umount /mnt/samba/new

# mount /mnt/samba/new

# mount | grep new
ad-rhs-srv1.cloud.lab.eng.bos.redhat.com:/new on /mnt/samba/new type fuse.glusterfs (rw,allow_other,max_read=131072)

Notice the difference in the mounted options. If ACL is enabled using setfacl, it fails in the first mounted state but succeeds after manually mounting it. 

Additional info:
Comment 2 surabhi 2013-08-07 05:54:34 EDT
Verified as follows:

Make an entry in fstab with acl option.
Fuse mount the volume
check the mount and it is showing 
10.16.159.42:/dis on /mnt/dis type fuse.glusterfs rw,allow_other,max_read=131072)
which is as expected.

With Big bend the new hook scripts doesn't do fuse mount and make entries in fstab so I did a manual mount and verified the acl option which we may require for AD setup.
Comment 3 Scott Haines 2013-09-23 18:32:16 EDT
Since the problem described in this bug report should be resolved in a recent advisory, it has been closed with a resolution of ERRATA. 

For information on the advisory, and where to find the updated files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1262.html

Note You need to log in before you can comment on or make changes to this bug.