Bug 9786 - user .inputrc corrupts key behavior
Summary: user .inputrc corrupts key behavior
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: readline   
(Show other bugs)
Version: 6.2
Hardware: i386
OS: Linux
medium
low
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-02-25 18:11 UTC by David D.W. Downey
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-03-27 12:00:01 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description David D.W. Downey 2000-02-25 18:11:48 UTC
System doesn't utilize backspace, home or DEL for users unless you delete
.inputrc from their dir and log out. root works fine out of the box.
Delete that file and normal behavior of keys.      Root is not affected by
this by default since he/she doesn't have an inputrc file installed by
default.

Comment 1 Nalin Dahyabhai 2001-04-07 01:33:58 UTC
This is the normal documented behavior (see the readline(3) man page).  If the
user's home directory includes a .inputrc file, it must include a line such as:
$include /etc/inputrc
to cause the system-wide inputrc to be read.  For this reason, there is no
default /etc/skel/.inputrc file supplied with RHL 6.2.


Note You need to log in before you can comment on or make changes to this bug.