Bug 978610 - SELinux is preventing /opt/google/chrome/chrome from 'append' accesses on the file /home/jonathan/libpeerconnection.log.
SELinux is preventing /opt/google/chrome/chrome from 'append' accesses on the...
Status: CLOSED DUPLICATE of bug 960792
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
17
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:f8e171d4b741116c991398bbce9...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-26 19:12 EDT by Jonathan Griffith
Modified: 2013-06-27 10:44 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-27 10:44:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jonathan Griffith 2013-06-26 19:12:15 EDT
Description of problem:
SELinux is preventing /opt/google/chrome/chrome from 'append' accesses on the file /home/jonathan/libpeerconnection.log.

*****  Plugin catchall (100. confidence) suggests  ***************************

If you believe that chrome should be allowed append access on the libpeerconnection.log file by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep chrome /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                unconfined_u:unconfined_r:chrome_sandbox_t:s0-s0:c
                              0.c1023
Target Context                unconfined_u:object_r:user_home_dir_t:s0
Target Objects                /home/jonathan/libpeerconnection.log [ file ]
Source                        chrome
Source Path                   /opt/google/chrome/chrome
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           google-chrome-stable-28.0.1500.52-207119.i386
Target RPM Packages           
Policy RPM                    selinux-policy-3.10.0-170.fc17.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 3.8.13-100.fc17.i686 #1 SMP Mon
                              May 13 13:51:09 UTC 2013 i686 i686
Alert Count                   2
First Seen                    2013-06-26 14:18:49 EDT
Last Seen                     2013-06-26 18:01:36 EDT
Local ID                      32ac4b24-9e15-48fb-aa7b-0d30764c51d6

Raw Audit Messages
type=AVC msg=audit(1372284096.563:69): avc:  denied  { append } for  pid=1385 comm="chrome" name="libpeerconnection.log" dev="dm-2" ino=656392 scontext=unconfined_u:unconfined_r:chrome_sandbox_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:user_home_dir_t:s0 tclass=file


type=SYSCALL msg=audit(1372284096.563:69): arch=i386 syscall=open success=no exit=EACCES a0=b7a8ea8c a1=8441 a2=1b6 a3=b7ab6b00 items=0 ppid=0 pid=1385 auid=1000 uid=1000 gid=1003 euid=1000 suid=1000 fsuid=1000 egid=1003 sgid=1003 fsgid=1003 ses=4 tty=(none) comm=chrome exe=/opt/google/chrome/chrome subj=unconfined_u:unconfined_r:chrome_sandbox_t:s0-s0:c0.c1023 key=(null)

Hash: chrome,chrome_sandbox_t,user_home_dir_t,file,append

audit2allow

#============= chrome_sandbox_t ==============
allow chrome_sandbox_t user_home_dir_t:file append;

audit2allow -R

#============= chrome_sandbox_t ==============
allow chrome_sandbox_t user_home_dir_t:file append;


Additional info:
hashmarkername: setroubleshoot
kernel:         3.8.13-100.fc17.i686
type:           libreport

Potential duplicate: bug 967055
Comment 1 Daniel Walsh 2013-06-27 10:44:05 EDT

*** This bug has been marked as a duplicate of bug 960792 ***

Note You need to log in before you can comment on or make changes to this bug.