Bug 978612 - Xorg crash during live install from KDE or on resolution change from GNOME "Displays" applet when using qxl with KMS, F19 host, F19 guest
Xorg crash during live install from KDE or on resolution change from GNOME "D...
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-qxl (Show other bugs)
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Dave Airlie
Fedora Extras Quality Assurance
: CommonBugs, Reopened
Depends On:
  Show dependency treegraph
Reported: 2013-06-26 19:31 EDT by Scott Dowdle
Modified: 2015-02-18 08:57 EST (History)
12 users (show)

See Also:
Fixed In Version: xorg-x11-drv-qxl-0.1.1-0.11.20130514git77a1594.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2015-02-18 08:57:34 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
Guest Xorg.0.log (46.86 KB, text/plain)
2013-07-11 18:00 EDT, Martin Kho
no flags Details

  None (edit)
Description Scott Dowdle 2013-06-26 19:31:12 EDT
Whenever I try to create a Fedora 19 VM with Spice/QXL (using Fedora 18 from the list since virt-manager doesn't list Fedora 19 yet) on a Fedora 19 host, the guest always dies during the install.

Here are the packages I have installed:

At some point during the install, the VM will become unresponsive and the CPU will be stuck at a fairly high level which stays constant.  The only thing that can be done is to force power off the VM.

With older releases of the packages I could switch the Video selection to something other than QXL and it would work.  Now those seem to cause other problems, especially when one tries to change the resolution inside of a desktop environment.  One of several things will happen when trying to switch resolutions... the X11 server will crash returning one to the display manager... or the physical host will become unresponsive and require a power cycle.  I didn't try every Spice / non-QXL combination but I have done several.  I'm guessing the various issues lead back to a common cause.

Oddly, Fedora 18 Spice/QXL guests works just fine.  It is only the combination of a Fedora 19 Spice/QXL|other and a Fedora 19 host where I have no end of problems.

I have encountered this situation on at least two different physical hosts with vastly different CPUs (Core 2 Duo and i7) and vastly different video cards (Intel onboard vs Radeon HD 2400) and I believe it is easily reproducible.

Sorry I've been lacking in hard, technical details but I'm not sure what package to file against nor exactly how to debug.  I haven't really noticed anything noteworthy in any of the logs.

So to try to duplicate, use virt-manager with stock settings (assuming SPICE and QXL are stock?), create a Fedora 19 VM on a Fedora 19 host... and see what happens.  As I said, it will sometimes run for a little while before the VM dies.  One time I got through an entire install but the post-install, rebooted system died shortly thereafter.  99.9% of the time it dies fairly early in the install process.

Fedora 18 Spice/QXL guests working on Fedora 19 hosts without incident has also been a constant across the machines I've been working with.
Comment 1 Scott Dowdle 2013-06-26 20:04:36 EDT
I looked at the Fedora 19 common bugs page and found mention of bug # 965101 which appears to be closed.  This bug seems to be very close to that bug BUT the fix noted (xorg-x11-drv-qxl-0.1.1-0.9.20130514git77a1594.fc19.x86_64 installed in the guest) does not work.

Please note that this appears to happen with both 32 bit and 64 bit guests on 64bit hosts.
Comment 2 Christophe Fergeau 2013-06-27 09:16:53 EDT
I just tested an install of f19 final-rc2 in virt-manager on an up-to-date f19 system, and I did not hit any such issues, it installed and I could reboot and log into a gnome desktop in the VM. My virt-manager version must have been newer than yours (0.10.0-1) as I have a Fedora 19 option in the known OSes.
Comment 3 Scott Dowdle 2013-06-27 14:22:29 EDT
Christophe Fergeau, Thanks for taking the time to check it.

I enabled the updates-testing repo and upgraded virt-manager so I match your version.  I retested and still ran into the problem.  The one difference though is that I'm installing a KDE-based remix instead of the default gnome media you did.  I'm downloading the stock gnome media now (F19 RC3) and am going to give that a try.  Will report my findings.
Comment 4 Scott Dowdle 2013-06-27 15:13:41 EDT
I've only done one install on one machine... I picked Fedora 19 (which shows up as an option now like you said) and yes, the GNOME media installed... but post install in the GNOME desktop, when I tried to change from the default resolution (1024x768?) to something larger, the VM became unresponsive and after a minute or two my host became unresponsive. I had to power cycle.

I'll have to do more testing.  My guess at this point, assuming it is reproducible, is that KDE triggers whatever the problem is faster... as does changing resolutions... but that is completely guesswork on my part.
Comment 5 Christophe Fergeau 2013-06-28 05:57:46 EDT
Ah, I hadn't tested the resolution changing, I only checked that logging into GNOME worked. I indeed get a Xorg crash when changing the resolution to something bigger in GNOME's displays settings. Interestingly, when doing things from the commandline with xrandr, I did not trigger such crashes.
Here is a backtrace of the Xorg crash:

Program received signal SIGSEGV, Segmentation fault.
sse2_blt (src_bits=<optimized out>, dst_bits=<optimized out>, src_stride=<optimized out>, dst_stride=<optimized out>, src_bpp=<optimized out>, src_x=<optimized out>, src_y=0, dest_x=0, dest_y=dest_y@entry=0, width=width@entry=1280, height=<optimized out>, 
    height@entry=800, dst_bpp=<optimized out>, imp=<optimized out>) at pixman-sse2.c:4762
4762                xmm0 = load_128_unaligned ((__m128i*)(s));
(gdb) bt
#0  sse2_blt (src_bits=<optimized out>, dst_bits=<optimized out>, src_stride=<optimized out>, dst_stride=<optimized out>, src_bpp=<optimized out>, src_x=<optimized out>, src_y=0, dest_x=0, dest_y=dest_y@entry=0, width=width@entry=1280, height=<optimized out>, 
    height@entry=800, dst_bpp=<optimized out>, imp=<optimized out>) at pixman-sse2.c:4762
#1  0x00000031b529035b in sse2_blt (height=800, width=1280, dest_y=0, dest_x=<optimized out>, src_y=<optimized out>, src_x=<optimized out>, dst_bpp=<optimized out>, src_bpp=<optimized out>, dst_stride=<optimized out>, src_stride=<optimized out>, 
    dst_bits=<optimized out>, src_bits=<optimized out>, imp=<optimized out>) at pixman-sse2.c:4819
#2  sse2_composite_copy_area (imp=<optimized out>, info=<optimized out>) at pixman-sse2.c:4812
#3  0x00000031b520b841 in pixman_image_composite32 (op=op@entry=PIXMAN_OP_SRC, src=<optimized out>, mask=mask@entry=0x0, dest=<optimized out>, src_x=src_x@entry=0, src_y=src_y@entry=0, mask_x=0, mask_y=0, dest_x=0, dest_y=0, width=1280, height=800) at pixman.c:707
#4  0x00000031b520b8e3 in pixman_image_composite (op=op@entry=PIXMAN_OP_SRC, src=<optimized out>, mask=mask@entry=0x0, dest=<optimized out>, src_x=src_x@entry=0, src_y=src_y@entry=0, mask_x=<optimized out>, mask_x@entry=0, mask_y=<optimized out>, mask_y@entry=0, 
    dest_x=<optimized out>, dest_x@entry=0, dest_y=<optimized out>, dest_y@entry=0, width=<optimized out>, width@entry=1280, height=<optimized out>, height@entry=800) at pixman.c:730
#5  0x00007f4812618d15 in download_box_no_update (surface=0x1369750, surface=0x1369750, y2=<optimized out>, x2=<optimized out>, y1=0, x1=0) at qxl_surface.c:133
#6  qxl_download_box (surface=surface@entry=0x1369750, x1=0, y1=0, x2=<optimized out>, y2=<optimized out>) at qxl_surface.c:145
#7  0x00007f4812618e07 in qxl_surface_prepare_access (surface=0x1369750, pixmap=0x138d970, region=0x7fff5ba772c0, access=<optimized out>) at qxl_surface.c:178
#8  0x00007f481262434f in uxa_prepare_access (pDrawable=<optimized out>, region=0x7fff5ba77330, region@entry=0x0, access=access@entry=UXA_ACCESS_RO) at uxa.c:172
#9  0x00007f481262e673 in uxa_check_composite (op=op@entry=1 '\001', pSrc=pSrc@entry=0x19d0b10, pMask=pMask@entry=0x0, pDst=pDst@entry=0x19d0b90, xSrc=xSrc@entry=0, ySrc=ySrc@entry=27, xMask=xMask@entry=0, yMask=yMask@entry=0, xDst=xDst@entry=0, yDst=yDst@entry=0, 
    width=width@entry=153, height=height@entry=49) at uxa-unaccel.c:441
#10 0x00007f481262b27f in uxa_composite (op=<optimized out>, pSrc=0x19d0b10, pMask=0x0, pDst=0x19d0b90, xSrc=0, ySrc=27, xMask=0, yMask=0, xDst=<optimized out>, yDst=<optimized out>, width=153, height=49) at uxa-render.c:1694
#11 0x0000000000520292 in damageComposite ()
#12 0x00000000004d5607 in compNewPixmap ()
#13 0x00000000004d63c5 in compAllocPixmap ()
#14 0x00000000004d4ccf in compRealizeWindow ()
#15 0x000000000045f0d6 in RealizeTree ()
#16 0x0000000000461eb5 in MapWindow ()
#17 0x0000000000431e28 in ProcMapWindow ()
#18 0x0000000000436df7 in Dispatch ()
#19 0x00000000004263fa in main ()
Comment 6 Christophe Fergeau 2013-06-28 05:59:02 EDT
This happened with a f19 final-rc2 with:
Comment 7 Christophe Fergeau 2013-06-28 06:57:30 EDT
12:42 < teuf> airlied: any idea about that backtrace in https://bugzilla.redhat.com/show_bug.cgi?id=978612 ?
12:44 < airlied> I thought I'd fixed that
12:45 < airlied> though granted I only tested with xrandr as well
12:45 < airlied> http://cgit.freedesktop.org/xorg/driver/xf86-video-qxl/commit/?id=1b4d51be0502224c5b6c165b7aaec02d7e782c8c
Comment 8 Dave Airlie 2013-06-28 07:27:23 EDT
dang, the last minute fix to stop the characters disappearing, triggers this, I'll get on it first thing next week and track it down. Aarggh.
Comment 9 Christophe Fergeau 2013-06-28 07:45:45 EDT
nomodeset on the kernel command line avoids this issue fwiw.
Comment 10 Adam Williamson 2013-06-28 11:26:12 EDT
Better summary.
Comment 11 Scott Dowdle 2013-06-28 11:37:32 EDT
Adam that would be true if the crash wasn't also easily reproducible (at least for me) simply by using KDE or XFCE... but yeah, your alteration is easier to understand and still accurate. :)
Comment 12 Adam Williamson 2013-06-28 12:57:31 EDT
scott: oh, sorry, I missed that. jreznik actually saw something similar in a KDE install during testing yesterday, but I couldn't reproduce it.
Comment 13 Adam Williamson 2013-06-28 13:53:46 EDT
FWIW I just ran another F19 Final KDE live install, F19-guest-on-F19-host, x86_64 both, and didn't reproduce this that time either. There must be some kind of timing or config wrinkle to it, I guess.
Comment 14 Fedora Update System 2013-06-29 07:42:22 EDT
xorg-x11-drv-qxl-0.1.1-0.10.20130514git77a1594.fc19 has been submitted as an update for Fedora 19.
Comment 15 Fedora Update System 2013-06-29 14:22:57 EDT
Package xorg-x11-drv-qxl-0.1.1-0.10.20130514git77a1594.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing xorg-x11-drv-qxl-0.1.1-0.10.20130514git77a1594.fc19'
as soon as you are able to.
Please go to the following url:
then log in and leave karma (feedback).
Comment 16 Scott Dowdle 2013-07-01 14:07:19 EDT
The updated testing packages work better but they are still very error prone.  Switching resolutions in pretty much any desktop environment (I tried KDE, XFCE and GNOME) crashes the X server.

I did update the VM to all of the updates that came out this weekend (for example, kernel 3.9.8) and that didn't help.  Still crashes X (but not the VM) when one attempts a resolution change.

The default resolution seems to work well enough which allows one to do an install... but beyond that, not very functional.
Comment 17 Dave Airlie 2013-07-02 00:35:47 EDT
it really helps if you apply the patch in the package, sorry guys

11 is building will update the bug soon.
Comment 18 Fedora Update System 2013-07-02 21:40:19 EDT
Package xorg-x11-drv-qxl-0.1.1-0.11.20130514git77a1594.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing xorg-x11-drv-qxl-0.1.1-0.11.20130514git77a1594.fc19'
as soon as you are able to.
Please go to the following url:
then log in and leave karma (feedback).
Comment 19 Martin Kho 2013-07-11 17:59:39 EDT

I used the update from comment #18 in a fc19-kde-guest on fc19-kde-host. Still see some issues. When opening konsole cpu usage raises to 100% and X gets very slow. In the attachment there are lots of 'qxl_kms_surface_create: Bad bpp: 1 (1)'

Martin Kho
Comment 20 Martin Kho 2013-07-11 18:00:27 EDT
Created attachment 772452 [details]
Guest Xorg.0.log
Comment 21 Fedora Update System 2013-07-11 23:00:31 EDT
xorg-x11-drv-qxl-0.1.1-0.11.20130514git77a1594.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 22 Scott Dowdle 2013-07-29 16:16:28 EDT
This bug is back again.  Same exact systems... Fedora 17 and 18 work great on a Fedora 19 host... a Fedora 19 VM on a Fedora 19 host, not so much.  My KDE install continues to die at some point during the install... on multiple machines.

Versions of things I have installed:

Comment 23 Andres Martinson 2013-08-06 23:54:50 EDT
This bug seems biting here too.

I am using fc19 guest (default install) on fc19 host using kvm and spice/qxl.

However I've noticed that the problems are present when qemu command line option -machine has arguments pc-i440fx-1.4 or pc-1.3. If the -machine is pc-1.2 or lower then the poor performance and instability problems go away but VM's resolution change does not stick.

To clarify, when qemu's -machine option is pc-1.2 dmesg's output about about drm and qxl is:
[    0.620900] [drm] Initialized drm 1.1.0 20060810
[    0.627902] [drm:qxl_pci_probe] *ERROR* qxl too old, doesn't support client_monitors_config, use xf86-video-qxl in user mode
[    0.627957] qxl: probe of 0000:00:02.0 failed with error -22

But guest's gnome or mate's resolution change does not survive past logout from the guest's desktop.

When qemu's -machine option is pc-1.3 or pc-i440fx-1.4 dmesg's output with regards to drm and qxl is:
[    0.521392] [drm] Initialized drm 1.1.0 20060810
[    0.545264] [drm] Device Version 0.0
[    0.545267] [drm] Compression level 0 log level 0
[    0.545268] [drm] Currently using mode #0, list at 0x488
[    0.545269] [drm] 12286 io pages at offset 0x1000000
[    0.545269] [drm] 16777216 byte draw area at offset 0x0
[    0.545270] [drm] RAM header offset: 0x3ffe000
[    0.545271] [drm] rom modes offset 0x488 for 118 modes
[    0.548035] [TTM] Zone  kernel: Available graphics memory: 1025792 kiB
[    0.548037] [TTM] Initializing pool allocator
[    0.548040] [TTM] Initializing DMA pool allocator
[    0.548044] [drm] qxl: 16M of VRAM memory size
[    0.548045] [drm] qxl: 63M of IO pages memory ready (VRAM domain)
[    0.552726] [drm] main mem slot 1 [f4000000,3ffe000)
[    0.553280] [drm] fb mappable at 0xF4000000, size 3145728
[    0.553282] [drm] fb: depth 24, pitch 4096, width 1024, height 768
[    0.553304] checking generic (f4000000 130000) vs hw (f4000000 1000000)
[    0.553305] fb: conflicting fb hw usage qxldrmfb vs VESA VGA - removing generic driver
[    0.553316] Console: switching to colour dummy device 80x25
[    0.553425] fbcon: qxldrmfb (fb0) is primary device
[    0.561615] Console: switching to colour frame buffer device 128x48
[    0.562871] qxl 0000:00:02.0: fb0: qxldrmfb frame buffer device
[    0.562872] qxl 0000:00:02.0: registered panic notifier
[    0.562876] [drm] Initialized qxl 0.1.0 20120117 for 0000:00:02.0 on minor 0

But in this case graphics performance causes high cpu utilization and occasional freezes with cpu pegged at 100%.

On host installed:

On guest installed:
Comment 24 Scott Dowdle 2013-08-22 16:35:09 EDT
After a few kernel updates, spice package updates, and qemu/kvm package updates... I just created a new VM of Fedora 19 on Fedora 19 with SPICE and while there was a freeze that lasted for several seconds during the install... it did come back to life... so I was able to get through a complete KDE install... and then run the machine successfully for a reasonable bit of time post-install without any problems.

What package or combination of things fixed it?  I'm not sure but to the best of my knowledge, this bug has been fixed.

Can anyone confirm that they can't trigger the bug anymore either?

Here are the packages I have installed currently for comparison:

Comment 25 Scott Dowdle 2013-11-04 17:02:25 EST
I'm running Fedora 20 and I still have this bug last time I checked.  I just gave up (for the time being) on the SPICE / QXL combo and go with SPICE / VMVGA instead.  Performance isn't as good but it is stable.
Comment 26 Fedora End Of Life 2015-01-09 17:10:10 EST
This message is a notice that Fedora 19 is now at end of life. Fedora 
has stopped maintaining and issuing updates for Fedora 19. It is 
Fedora's policy to close all bug reports from releases that are no 
longer maintained. Approximately 4 (four) weeks from now this bug will
be closed as EOL if it remains open with a Fedora 'version' of '19'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not 
able to fix it before Fedora 19 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.
Comment 27 Fedora End Of Life 2015-02-18 08:57:34 EST
Fedora 19 changed to end-of-life (EOL) status on 2015-01-06. Fedora 19 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.